Jump to content
RealModScene
MaesterRowen

Aurora - Coverflow Editor & CFEditDll

Recommended Posts

Hello everyone,

 

We've decided to release our Coverflow Layout Editor tool (with Aurora Plugin ) for you all to play around with and create your own custom coverflow layouts.   You can adjust the layout, the camera, the lighting, and all of the different modes.

 

You can then save your layout and share it with others!

 

As usual, if you like what we're doing here, and want to support and encourage us to continue releasing tools and apps, feel free to 
btn_donate_LG.gif

 

Download:  CoverflowLayoutEditor.rar

 

How to Use:

Step #1.  Copy the CFEditDLL.xex into your Aurora/Plugins folder and restart Aurora.  

Step #2.  Confirm that the DLL is loaded by checking the Loaded Modules dialog (Back button from Aurora main menu)

Step #3.  Launch CoverFlow Editor on your PC

Step #4.  Enter your xbox IP

Step #5.  Play with all the different settings.

Step #6.  Once you've created all the different modes you want, save the layout to disk

Step #7.  Copy the Layout into your Aurora/Media/Layouts folder and use it whenever you want!

 

Notes:   I recommend you have both your PC and Xbox360 on a wired connection.  I've experienced connectivity issues when using WiFi. Additionally, I recommend removing the CFEditDLL.xex when you are not using it so your normally running dash is not impacted.

 

Screenshots:

54b6g.jpg

 

14wakcn.jpg

Share this post


Link to post
Share on other sites

Outstanding!! Nothing more to say aside of thank you to everyone involved!!  Tools like this really bring life back to setting up a console the way the user wants it,  great work!

 

I have intended to make a donation to the team(s) here for ages but have been slim on funds, I now have a small bit I can spare, it won't be a lot, but I know in these efforts every bit is appreciate and I will be more than happy to donate what I can, I also urge others to do so as well if you appreciate the various software the devs give us to use with our consoles!

 

edit: wait,, someone else actually likes blur still besides me :o LOL

 

edit 2: after some toying with this, I just had to come back and say bravo once again  :clap:  :clap:  :clap:  :clap:  :clap:, this is an amazing plugin/tool combo! I know they are not the same thing, but a certain m$ tool I use for UI editing on my kit is absolute garbage when compared to the performance of this. Hands down coolest thing i've seen in the scene since the custom xam hud!!!!!      

  • Like 4

Share this post


Link to post
Share on other sites

Can't get it to run on my Win7 virtual machine. It connects and pops up in Aurora, but the status on the Windows app just says "UDP Listener Active!". When I try to change any settings it throws an unhanded exception error, "object reference not set to an instance of an object". I guess if wifi was iffy then running NAT through a VM is even worse. Darn, wanted to mess around with it too.

Share this post


Link to post
Share on other sites

Can't get it to run on my Win7 virtual machine. It connects and pops up in Aurora, but the status on the Windows app just says "UDP Listener Active!". When I try to change any settings it throws an unhanded exception error, "object reference not set to an instance of an object". I guess if wifi was iffy then running NAT through a VM is even worse. Darn, wanted to mess around with it too.

There's a menu option that gets the current settings, use that, if values change it's working fine ;)

Share this post


Link to post
Share on other sites

There's a menu option that gets the current settings, use that, if values change it's working fine ;)

 

Thanks for the advice, unfortunately I tried the import from console option with no change. Aurora plugin makes connection fine, but no change in status of the app. Still says Status UDP Listener Active! instead of Xbox Connection Established like your screenshot above. Not a big deal, just wanted to play around with it. If it's any help here's the  exception... http://pastebin.com/NwyxZQje

 

edit: OK, so looking into it further I think the problem might be that it's built on .NET framework 4.0 and I run 4.5. Just a quick google tells me

 

"The .NET Framework 4.5 and its point releases are backward-compatible with apps that were built with earlier versions of the .NET Framework. In other words, apps and components built with previous versions will work without modification on the .NET Framework 4.5. However, by default, apps run on the version of the common language runtime for which they were developed, so you may have to provide a configuration file to enable your app to run on the .NET Framework 4.5"

 

So just a stab in the dark that I have some issue with backward compatibility. IDK

Share this post


Link to post
Share on other sites

Thanks for the advice, unfortunately I tried the import from console option with no change. Aurora plugin makes connection fine, but no change in status of the app. Still says Status UDP Listener Active! instead of Xbox Connection Established like your screenshot above. Not a big deal, just wanted to play around with it. If it's any help here's the  exception... http://pastebin.com/NwyxZQje

 

edit: OK, so looking into it further I think the problem might be that it's built on .NET framework 4.0 and I run 4.5. Just a quick google tells me

 

"The .NET Framework 4.5 and its point releases are backward-compatible with apps that were built with earlier versions of the .NET Framework. In other words, apps and components built with previous versions will work without modification on the .NET Framework 4.5. However, by default, apps run on the version of the common language runtime for which they were developed, so you may have to provide a configuration file to enable your app to run on the .NET Framework 4.5"[/size]

 

So just a stab in the dark that I have some issue with backward [/size]compatibility. IDK

It could also be your firewall blocking it somewhere, or that you're not in the same network (despite what you think) perhaps try bridging the network cards? (i use this with Windows 8.1 and have .NET 4.5 and even 4.6, it still runs fine for me)

Share this post


Link to post
Share on other sites

It could also be your firewall blocking it somewhere, or that you're not in the same network (despite what you think) perhaps try bridging the network cards? (i use this with Windows 8.1 and have .NET 4.5 and even 4.6, it still runs fine for me)

Thanks again for the advice, working fine now. Changed VM from NAT to Bridged and it connect right away. I appreciate the help.  :thumbsup:

  • Like 1

Share this post


Link to post
Share on other sites

Awesome little app. I was just messing with it, and when I get some time I will see what I can do with it. I love how it updates on the xbox the moment you change a value. :)

Share this post


Link to post
Share on other sites

I wanted to use this tool to create a new configuration for my skin "Avengers" unfortunately still have an error that does not allow me to do anything. I am using Windows 8.1 and Net Framwork 4.6 :(... Good Work all 

Share this post


Link to post
Share on other sites

I wanted to use this tool to create a new configuration for my skin "Avengers" unfortunately still have an error that does not allow me to do anything. I am using Windows 8.1 and Net Framwork 4.6 :(... Good Work all 

If you are talking about how it bombs out the moment you change a setting, try loading a pre made theme, or setting a name, and go from there I ran in to this while I was messing with it, and was going to drop a line to MaesterRowen about it in the morning. :) trust me it works otherwise. :)

 

edit: Message sent to Maester Rowen, so maybe he will look into that. :)

Share this post


Link to post
Share on other sites

i have disinstalled and re installed Framwork v 4.6 and now work fine   :)

edit: Not work on Windows 7 VM :/

http://www.realmodscene.com/index.php?/topic/5255-aurora-coverflow-editor-cfeditdll/#entry42803 read this post...

Both the console and the VM needs to be ion the SAME network, meaning you may have to set the VM network device to be bridged and not NAT

  • Like 1

Share this post


Link to post
Share on other sites

Awesome app here but for the life of me it keeps bugging out on me. Have read and tried everything both xbox and pc are on wired connections sometimes the changes I make happen most of the time they dont and throw exception errors. But yeah really cool for those who can get it working major props to the devs for this nifty little tool

  • Like 3

Share this post


Link to post
Share on other sites

Awesome app here but for the life of me it keeps bugging out on me. Have read and tried everything both xbox and pc are on wired connections sometimes the changes I make happen most of the time they dont and throw exception errors. But yeah really cool for those who can get it working major props to the devs for this nifty little tool

Make sure to load an existing Coverflow before you start changing values...

Otherwise, send me the error message you get and i'll help you fix it

  • Like 1

Share this post


Link to post
Share on other sites

Make sure to load an existing Coverflow before you start changing values...

Otherwise, send me the error message you get and i'll help you fix it

I will give it a whirl now when I load an existing coverflow from the file folder that came with the program will it load up on the cosole as well also will get that error firing up the rig now to see what I can get.

Share this post


Link to post
Share on other sites

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Net.Sockets.SocketException (0x80004005): Only one usage of each socket address (protocol/network address/port) is normally permitted

at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.Sockets.Socket.Bind(EndPoint localEP)

at System.Net.Sockets.UdpClient..ctor(Int32 port, AddressFamily family)

at CFLayoutEditor.frmMain.SendMessageEx(String property, String type, String value)

at CFLayoutEditor.frmMain.SendMessage(String property, List`1 value)

at CFLayoutEditor.frmMain.SendLeftPos()

at CFLayoutEditor.frmMain.SendLayout()

at CFLayoutEditor.frmMain.openToolStripMenuItem_Click(Object sender, EventArgs e)

at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)

at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)

at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)

at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)

at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)

at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ScrollableControl.WndProc(Message& m)

at System.Windows.Forms.ToolStrip.WndProc(Message& m)

at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

That is the error and the dialoge box says an unhandled exception has occured, Only one usage of each socket address(protocol/network address/port is normally permitted)

I get this when I choose a layout it does switch on console but when I start to change values it does nothing on the console side

Share this post


Link to post
Share on other sites

It seems that something on your computer is using port 9991, try using a different computer or try disabling anything that could be using this port...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×