Jump to content
RealModScene
DashingRhythm

Both Aurora Asset Editor and Aurora dash itself no longer downloading assets from Xbox.com?

Recommended Posts

I noticed last night that for some reason Aurora wasn't downloading Banners, Synopsis etc for all the games I had scanned in. Pushing the refresh button wouldn't do anything so I double checked Dashlaunch to make sure livestrong was still disabled and yes, it is. I then went on to Aurora Asset Editor to grab the assets manually and sure enough that failed too as you can see by my error.log file below. Not sure if this is a issue on my end or not but an explanation would be appreciated. If it helps I know of someone else not being able to download assets from Aurora Asset Editor too as of last night, receiving the same error as me.

Many thanks

error.log

  • Like 1

Share this post


Link to post
Share on other sites

Thats the remote Server. Maybe the request got corrupted somehow.

İ dont know which server is being requested to, xboxunity or xbox.com or anything else.

İf thats team Phoenix server, they could look for request logs on server side.

İf its xbox, maybe the url parameters have changed, that would mean a patch is needed. Maybe its temporary. Eitherway, you may have to find out the request parameters. You can do that with wireshark.

 

Edit: that was all console specific. İ dont know about Aurora Asset Editor, but it would apply to the same basics.

Share this post


Link to post
Share on other sites
2 hours ago, saywaking said:

Thats the remote Server. Maybe the request got corrupted somehow.

İ dont know which server is being requested to, xboxunity or xbox.com or anything else.

İf thats team Phoenix server, they could look for request logs on server side.

İf its xbox, maybe the url parameters have changed, that would mean a patch is needed. Maybe its temporary. Eitherway, you may have to find out the request parameters. You can do that with wireshark.

 

Edit: that was all console specific. İ dont know about Aurora Asset Editor, but it would apply to the same basics.

I believe its on the xbox.com side of things as I can download from xboxunity no issue. I think what you are saying about url paramenters changing might be the case as this isn't just happening to me.

Share this post


Link to post
Share on other sites
On 9/29/2018 at 1:35 PM, DashingRhythm said:

I believe its on the xbox.com side of things as I can download from xboxunity no issue. I think what you are saying about url paramenters changing might be the case as this isn't just happening to me.

Something changed with the xbox.com website, it's no longer accepting the same parameters as it used to, it now returns a 500 internal error meaning the server software was unable to handle the request (it basically crashed) probably due to a missing required parameter that was added or that the format of all the parameters changed

Share this post


Link to post
Share on other sites

Yes I have the same problem, Cover and Background images and Title Updates are visible, but can't see Synopsis and little Banners. Both livestrong and liveblock are set to false. I was about to reinstall Aurora before seeing this post and realising i'm not the only one

Share this post


Link to post
Share on other sites

I fixed Aurora Asset Editor - move from catalog.xboxlive.com requests to parsing game page at marketplace.xbox.com and change xml to html parser. It also contains game descriptions and stars rating that can be used into Aurora dash if xboxlive.com never been available. But I can`t find big covers here (no need for AssetEditor but for Aurora dash).

Share this post


Link to post
Share on other sites

If you need download backgrounds, screenshots and banners images - use Assent Editor. I can`t fix Aurora dash(closed source code) - just wait fix from team or may be catalog.xbox.com back to work.

Share this post


Link to post
Share on other sites

I'm waiting for at least an update too,i had to reinstall aurora and now i have no information on any of my games oof ;-;

But seriously,it's been a while,and there's been no update at all on this.

Share this post


Link to post
Share on other sites

I think it will take them some time to make a good fix. The solution from Dex9999 for the Asset Editor works with an HTML parser, while XML is preferable. I think the Aurora team will try to find that.

There are always two options.: Fast and not so good or taking your time and do it good.

So I do not mind to have a little patience...

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...