Jump to content
RealModScene
Octal450

J-Runner with Extras (17559) - Built in Timings, Bugfixes, and New Features!

Recommended Posts

On 1/1/2022 at 1:38 AM, Octal450 said:

My pleasure, thanks for reporting it!

Happy New Year!

Kind Regards,
Josh

Hello Josh and happy 2022 thank you for your awesome work . i hope that this bug report may be of interest to you  . i tried to create a new retail nand without bad blocks  using  a glitch nand with bad blocks with the  "create an image without nandump.bin "  using the extracted nand files but i see that you removed it in 3.1.0.b . i created one using your software but retail nand keeps the bad blocks . i used another jrunner to complete the task.

 

hope it helps in any way

Share this post


Link to post
Share on other sites

@Eruil would you be able to send me the dump so I can check?

Also - you can use SHIFT+click to access the old system.

Kind Regards,
Josh

Share this post


Link to post
Share on other sites
On 1/10/2022 at 2:36 PM, willerson said:

@Octal450 SMC+ affects RGH3 or it is a different thing? i should select SMC+ when building RGH3 or not? thanks for the software.

Stop it, get the update :)

You will quickly find, that you cannot select SMC+ and RGH3 at the same time. RGH3 has it own SMC.

Kind Regards,
Josh

Share this post


Link to post
Share on other sites
13 hours ago, Octal450 said:

@Eruil would you be able to send me the dump so I can check?

Also - you can use SHIFT+click to access the old system.

Kind Regards,
Josh

no prob . i made it to another coleague in EOL forum ;D . i recompiled a bad block glitch nand to a retail with no bad blocks :D 

https://mega.nz/file/BU1GxLbI#VrYSaxaZ6ns1dSRE4_OxqWSvnBoILd1lMBRwXGooa6I 

 

i tested in your jrunner version. i selected clean smc and i pressed the left click + shift in the "create donor nand option " . it worked . thanks mr davidson ;D 

Share this post


Link to post
Share on other sites

why in the new J-Runner with Extras Session: 01.15.2022 16:27:20 Version: 3.1.0b didn't add bootloader 13182? for dashboard 17599?

Share this post


Link to post
Share on other sites
22 hours ago, Eruil said:

no prob . i made it to another coleague in EOL forum ;D . i recompiled a bad block glitch nand to a retail with no bad blocks :D 

https://mega.nz/file/BU1GxLbI#VrYSaxaZ6ns1dSRE4_OxqWSvnBoILd1lMBRwXGooa6I 

 

i tested in your jrunner version. i selected clean smc and i pressed the left click + shift in the "create donor nand option " . it worked . thanks mr davidson ;D 

Thanks friend. I will investigate and make a patch release later this month.

4 hours ago, djon said:

why in the new J-Runner with Extras Session: 01.15.2022 16:27:20 Version: 3.1.0b didn't add bootloader 13182? for dashboard 17599?

Sorry, I have absolutely no idea what you are trying to tell me. 13182 is placed by check WB 2K ok?

Kind Regards,

Josh

  • Like 1

Share this post


Link to post
Share on other sites
On 1/14/2022 at 12:34 AM, Eruil said:

Hello Josh and happy 2022 thank you for your awesome work . i hope that this bug report may be of interest to you  . i tried to create a new retail nand without bad blocks  using  a glitch nand with bad blocks with the  "create an image without nandump.bin "  using the extracted nand files but i see that you removed it in 3.1.0.b . i created one using your software but retail nand keeps the bad blocks . i used another jrunner to complete the task.

 

hope it helps in any way

@Eruil Can you tell me more how to reproduce? I loaded your dump, and used the donor nand wizard and the output has no bad blocks:

image.png.a89875099717bad60f62feff4cd4a8e3.png

 

That is because "create image without nanddump.bin" and "Donor Nand Creator" both do not use the original dump, they do a fresh image.

Please provide me steps on how to reproduce this so I can fix it!

Kind Regards,
Josh4

Share this post


Link to post
Share on other sites

 

4 hours ago, Octal450 said:

@Eruil Can you tell me more how to reproduce? I loaded your dump, and used the donor nand wizard and the output has no bad blocks:

image.png.a89875099717bad60f62feff4cd4a8e3.png

 

That is because "create image without nanddump.bin" and "Donor Nand Creator" both do not use the original dump, they do a fresh image.

Please provide me steps on how to reproduce this so I can fix it!

Kind Regards,
Josh4

i used the nanndump 17150 with badblocks and i tried to create another with 17559 dash in your jrunner version . the result was an updated nand with same bad blocks . i extracted files (kv.bin, fcrt.bin, etc...)  and i compiled a new retail  one with jrunner 0.8  benmitnick  using the "create a new nand without nandump" .  then i finally used that retail with no bad blocks to create a rgh 3 17559 nand .  then i tried what you said about shift + left click in the donor nand option copying extracted files (kv.bin , fcrt.bin, etc) to /xebuild/data and selecting "retail" with "clean smc" options. it worked . i thought that you had removed the  "create an image without the nanddump"  completely . im glad that its not what i thought ;D 

Captura de pantalla (1).png

Captura de pantalla (3).png

Captura de pantalla (2).png

Captura de pantalla (4).png

Captura de pantalla (5).png

Captura de pantalla (6).png

Share this post


Link to post
Share on other sites

Hi @Eruil

I understand that - but I cannot reproduce what you are saying where the resulting image has bad blocks. When I made it with the donor creator, it had no bad blocks!

So please provide me to reproduce the image that is having bad blocks.

Kind Regards,
Josh

Share this post


Link to post
Share on other sites
On 1/17/2022 at 5:38 AM, hunters-fox said:

delete

dude , you never sent the cpukey . we need updflash.bin (or any nand dump) + cpu key . cpukey its MANDATORY to create another nand

 

to octal. no prob dude . i think that you only need to ad in shortcuts the info about shift + left click to make  new nands. i tested it without any problem ;D 

Share this post


Link to post
Share on other sites

@Eruil

Yes it is, because I want to remove the old way and replace it with the Wizard way. So please, provide me the steps! Perhaps you did not use the wizard completely? For me, no bad blocks.

Please advise.

 

Kind Regards,

Josh

Share this post


Link to post
Share on other sites

@Octal450 so I successfully RGH 3 my falcon Xbox and my main purpose was to downgrade it to 6717 and run blades but after a successful flash I can boot into xell fine quickly but can’t boot into dash at all. When I turn on the Xbox just then center light comes on and that’s it

Share this post


Link to post
Share on other sites

Hello @Octal450

 

I inform you that the version of nandpro that incorporates the current version J-Runner with extras works with my MTX SPI NAND and its stock hex. After my pc had a driver problem, I reinstalled the MTX SPI NAND driver using the one included in the current version of J-Runner with extras, it worked fine with nandpro2e.

Sorry I didn't notice.

Thanks Josh for hard work

 

Share this post


Link to post
Share on other sites

Hello.

Using MTX SPI NAND Flasher V1.0, J-Runner with Extras 3.1.0b (Windows10 64bit pc) could not write ECC of Jasper 16mb.
There is a block that says Timed out when writing, and the xbox 360 won't turn on.

ECC could be written on J-Runner v0.3 Beta (8) (Windows7 64bit pc).

Strangely, another Jasper 16mb was able to write ECC with J-Runner with Extras 3.1.0b (Windows10 64bit pc).
Even if the console version is the same, it may or may not be writable.

The following can be written with J-Runner with Extras 3.1.0b (Windows10 64bit pc) so far.
Falcon, Trinity, Trinity 4gb, Corona v1

If you can, please take measures.

Share this post


Link to post
Share on other sites

Hi, @gonza3

We don't know why yet. The working J-Runner version is not reverse engineerable by us (obfuscate) and the source code has thsi fault.

Go to NAND-X menu and enable Matrix Flasher Mode. Then use Matrix Flasher drivers in the install. From there it will work.

Note: its intermittant. If you connect everything and then open J-Runner, it seems to work.

Kind Regards,
Josh

Share this post


Link to post
Share on other sites
12 hours ago, Octal450 said:

@Cerial_iQ no problem! I revert the change as 2e is newer.

Question, can you confirm if it works with corona?

Kind Regards, 

Josh

Hello,

At the moment I can not test that nandpro2e works correctly in corona, I only tested in jasper (SB and BB) and falcon

 

Matrix.png.0b24ac0ee48f91c4204e8edeac82b570.png

 

As I already mentioned, the best compatibility was obtained by using Nandpro2b_Armv3. So I think if you could choose between different versions of nandpro it would be the best.

This is just a suggestion, although if nandpro2e is verified to work in corona without problems, this will not be necessary. Just note that you have to use the driver included in J-Runner with Extras for the MTX SPI NAND Flasher

Thanks Josh 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...