Jump to content

ConnectX games occasionally hang when loading

Recommended Posts


I have a few games set up on an OpenFiler NAS and they run beautifully through ConnectX. I can play them fine, however sometimes if there's been a long pause between loading - such as starting a new level of a game, completing that level and loading the next - it will usually hang...

It doesn't freeze per se, because if there's animated graphics on the loading screen, it'll continue looping, but there will be no actual progress in the loading. Another example was when I tried playing Halo Anniversary Edition and all of a sudden the background music would start looping as if there's a scratch in the CD and all conversations are muted. Also, I can press the XBox button and the menu will pop open, and close again just fine - BUT if I try to return to Xbox menu (Y) the console will freeze completely.

My suspicion is that the NAS puts the harddrives into powersave mode and the Xbox somehow can't handle the delay while the drives are spinning up when accessed again. It ought to be simple to test this by disabling the powersave, but unfortunately I don't have that option :(

Now my question is, does anyone have any suggestions on how to work around this? Also, I'm curious to hear if anyone else have encountered this issue before?

UPDATE: So I tried a small theory I had, streaming a video on another machine from the same NAS as the game is located on, and while doing that it keeps the NAS "busy" and the game runs perfectly. So it seems my assumption is correct, the NAS is going into powersave but streaming a video keeps it from going into powersave since there's continuous trafic on the drive...

Now just to find out either how to prevent it from going into powersave mode while playing or how to make ConnectX not care about the spin-up time - having to stream a video while playing isn't really a good solution in the long run... Any suggestions?

Share this post

Link to post
Share on other sites

Your problem is the wired ethernet speed: 100Mbit.

Use external HDD or PEN drive on USB with 480Mbit,

the best and the fastest is the internal HDD with 3Gbit/sec !

Share this post

Link to post
Share on other sites

Hi Isty,

Thanks for taking the time to offer your input :)

In my opinion, the whole point of using ConnectX is to not have to use limited size external drives... This NAS can hold everything I could possibly dream of without having to transfer whatever games I feel like playing, in fact my entire library of games is on that thing - something neither the internal or any external drive has the capacity to do. Also, you say the internal drive delivers 3GBit/sec... There are no 2.5 inch 5400 rpm (or even 15000 rpm if you want to use SAS) that delivers that kind of speed - but yes, regardless, it's still a heck of a lot faster... The bus transfers 3gbit/sec, not the drive. But that's another discussion entirely :)

Trust me, speed isn't an issue as everything is running smoothly, no stuttering or otherwise.... Also would be strange that it only happens after periods of no loading, such as taking some time to run through a cached part of a level, or an entire level, between loads.

Also, it doesn't explain why it would run flawlessly when I stream a video from the NAS while playing to keep the drives from spinning down, and it solves the problem.

I just don't really want to have to stream something to make sure that the game will run :)

Share this post

Link to post
Share on other sites

Hey all, and phreon.

I have a 14TB nas/mini server/seedbox/downloader running and had the same problem a while back. Watched movies on my HTPC in TV room, and hdd would sleep, wake up 2 seconds later, causing a pause in the movie.

Download a program called hdd no sleep, works wonders. 1 or 2 things to change in the .ini file, but works really well.

Share this post

Link to post
Share on other sites

Hey Psychomaniac,

That's a very good suggestion, however I doubt it would work on a linux based NAS/SAN system such as OpenFiler. It's somewhat anal about what it'll allow in order to maintain system integrity and stability.

I did solve the issue, though! Turns out it was something as simple as a firmware update for my seagate drives that was needed. Apparently there was a firmware error in a specific batch of Seagate drives that caused the intellipark feature of the drives to go nuts, and essentially render them completely useless for raids.

What really threw me off was that it was only game streaming on the XBox that triggered this problem, nothing else, but I figured it was worth a try. And what do you know? It worked!

Thanks for your input guys :)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...