Jump to content
RealModScene
skullmonkey

Power Racer 270 wheel gas (light) stucked

Recommended Posts

HI,.
first Happy new Year :D
I'm trying to play with my son on a Power Racer 270 wheel but the gas is always on. Even if the pedals are not connected. It fills up till the first red light without pressing anything. The break works fine. I tried updating the firmware from Power Racer Customizer 3.1 but it says nothing. How do I invoke firmware update?
This is the current state:
image.png
 
Any suggestions would be appreciated.
Thanks,
Gorast

Share this post


Link to post
Share on other sites
2 hours ago, skullmonkey said:
HI,.
first Happy new Year :D
I'm trying to play with my son on a Power Racer 270 wheel but the gas is always on. Even if the pedals are not connected. It fills up till the first red light without pressing anything. The break works fine. I tried updating the firmware from Power Racer Customizer 3.1 but it says nothing. How do I invoke firmware update?
This is the current state:
image.png
 
Any suggestions would be appreciated.
Thanks,
Gorast

it could be someone setup the profile for gas to be always on??

i'd try to reset it to defaults and see??

 

https://fccid.io/WLE-XB10251/User-Manual/Users-Manual-1524335

 

 

Share this post


Link to post
Share on other sites

Did all that. Reset, delete, everything. Non helped. As soon as the controller is powered up its gas goes up. I'm thinking about opening its insides to see if I can spot some mechanical problem...altho it looks solid and it was never really used.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×