Jump to content
Sign in to follow this  

Oblivion Freeze at menu

Recommended Posts

I've got Oblivion stored on my hard drive and when I boot the game it freezes at the menu after I select either "Continue" or "New". I've tried booting it without DLC. I had to manually install the title update due to it not being on unity. It's the GOTY edition so the title update came off of the second disc. I've tried placing the title update in the cache and the content folder as well as booting without the TU. I'm at a loss and I'm jonesing from some Oblivion. I've even tried ripping a disc with a different media ID with the same result. 

This is the only game giving me issues. Has anyone experienced anything similar?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...