Jump to content
RealModScene
felida

[Tutorial] HUD modification

Recommended Posts

Here is a DETAILED video on how to change the HUD!! Credz to MaesterRowen and Gavin_Darkglider, and anyone else who has helped//

I SHOULD TELL YOU, that only the singed in/signed out need to be "byte-changed" as i was playing with the other stuff, and the FD -> BA wasn't necessary, and this stuff can be done without restarting aurora, as it pulls the info once you press the guide button.. VERY helpful in testing stuff!!

 

Edit By Gavin_Darkglider(The one who figured this out, Yeah that one. lol.):

The byte fix is one way to fix it, but the problem really happens when XUI Workshop converts the symbol º in the temperates, it doesnt do it properly. This is easily fixed, so no hex editor is needed by changing the square box looking symbol in the preset temperatures back to that symbol. You can do this by holding alt and pressing 167 on the number pad on the keyboard, and then releasing alt. if you save the XUI, you will never have to do it again, or worry about hex editing the file again. This is only needed on the "HomeTab" Hud Scenes, as they are the only one that show the temperatures. :) the rest will work as is. Felida must have missed that in my ramblings, on my progress on this. :)

 

Here is the link to the fixed XUI Tool Extensions. Happy Themeing. :)

XuiToolXamExtensions.rar

 

Edit:(by felida, the guy who makes the videos and gets whipped by Gavin, lmao) here is a video showing you what he means,   º  <--- copy that, no need to press alt+167.. or press it.. either way works, but i show you copy/paste works also!!

 

EDIT 3(or 4 lol): How to change Language Locale for those who are not US/ENG based (pix by MattieIta  :thumbup: )

2rnu3h1.jpg

1z6bbr7.jpg

post-51312-0-01067600-1432725823_thumb.jpg

post-51312-0-27950900-1432725841_thumb.jpg

  • Like 8

Share this post


Link to post
Share on other sites

something wrong with my xuitools?

5743e0c36de7eaa9d882e7d0cd0c4e36.png

This problem is fixed, he needed to change his regional settings to Unicode language programs

Share this post


Link to post
Share on other sites

Felida thank you very much

1f5dc986e2a78c0371e6a60552cc4af9.png

no problem man, always glad to help when i can  :thumbup:

Share this post


Link to post
Share on other sites

My Xuitool Looks same.

 

something wrong with my xuitools?

5743e0c36de7eaa9d882e7d0cd0c4e36.png

 

This problem is fixed, he needed to change his regional settings to Unicode language programs

 

Can you please tell my what i have to change and where?

Share this post


Link to post
Share on other sites

My Xuitool Looks same.

 

 

 

Can you please tell my what i have to change and where?

it is in your locale settings m8.. google it

Share this post


Link to post
Share on other sites

The only thing i found is non-Unicode. I´m using Win7. Tried to set to US but didnt´t work.

 

EDIT:

:wallbash:  Finally got it.  Now it works for me.

Share this post


Link to post
Share on other sites

The only thing i found is non-Unicode. I´m using Win7. Tried to set to US but didnt´t work.

 

EDIT:

:wallbash:  Finally got it.  Now it works for me.

Can you explain how please?i used google :D and set US but it didn't work

Share this post


Link to post
Share on other sites

In the Region Settings i´ve changed the Format to English (USA) and the keyboard standartlayout to English (USA) - US.

That´s it. Happy modding.

 

EDIT:

Forgot to say that you need to do the whole converting with the Settings, or else it will show up weird as before.

Share this post


Link to post
Share on other sites

Felida thank you very much

1f5dc986e2a78c0371e6a60552cc4af9.png

Would you mind sharing your hud? it looks pretty slick with the modified text and new LiNK icon.

Share this post


Link to post
Share on other sites

CPU/GPU instead of Processor/Graphics :chris:

that is just the text, you can change that yourself at anytime, watch the very last video i posted, the one with the º fix.. you can click/change the processor/graphics text to say CPU/GPU

Share this post


Link to post
Share on other sites

Bro I want to change Freestyle Home to Aurora in the HUD. So that when I press "Y", It opens Aurora and not FSD. This thread seams related. Plz guide me. I am a total noob. Plz tell in easy language and step by step...

Much needed help...

If not possible: then just give a quick summary of the steps needed...

Thanx...

Share this post


Link to post
Share on other sites

If not possible: then just give a quick summary of the steps needed...

Thanx...

the video shows you how to do it.. you just don't have to hex edit anything.. just change need to change the corrupt symbol to º in the temps part..

 
 

Bro I want to change Freestyle Home to Aurora in the HUD. So that when I press "Y", It opens Aurora and not FSD. This thread seams related. Plz guide me. I am a total noob. Plz tell in easy language and step by step...

Much needed help...

 

and the HUD has nothing to do with opening Aurora.. it just launches to the default dash designated in dashlaunch, meaning even if you change the text, and still have FSD as your default.. it would say "Aurora Home" but still boot to FSD

  • Like 3

Share this post


Link to post
Share on other sites

Hi Guys I have a question ,

I have tried today to modding the HUD  but i not understand how i make that XUIworkshop working every time when I launch XUIworkshop then come a Error

post-26634-0-68909400-1461156526_thumb.png

post-26634-0-64966100-1461156533_thumb.png

 

and my onther question is what File i must be Open for Modding HUD??

and where i copy the XuiToolXamExtensions??

someone help me Please :)

 

Thanks in Advance

Share this post


Link to post
Share on other sites

You need to get my extensions, which are needed by xuitool, and you need to change the location that XUI workshop is looking for the extensions for it. click ok, and then you can change that information.

  • Like 1

Share this post


Link to post
Share on other sites

You need to get my extensions, which are needed by xuitool, and you need to change the location that XUI workshop is looking for the extensions for it. click ok, and then you can change that information.

Thanks XUIWorkshop working now without errors :)

And my onther question is what File i must be Open for Modding HUD??

Is it Hudscene from extractet Skin??or what exactly??

Share this post


Link to post
Share on other sites

Thanks XUIWorkshop working now without errors :)

And my onther question is what File i must be Open for Modding HUD??

Is it Hudscene from extractet Skin??or what exactly??

They're in the Plugins\ folder... don't remember exact path, but... they're NOT part of the Aurora skin at all, they're part of the FSD Plugin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×