Jump to content
RealModScene
gavin_darkglider

Emulators That work with Auroras Autolaunch Feature

Recommended Posts

38 minutes ago, felida said:

Use my config mate.. is all i can say.. 

There is a difference between core specific configs, and general config..

 

 Thx! Where I can find it? BTW loading a Mame 2003 config crashes my xbox :(

 

Edit: found the .cfg file! 

  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, MKK hanzo said:

 Thx! Where I can find it? BTW loading a Mame 2003 config crashes my xbox :(

 

Edit: found the .cfg file! 

Yeah its in the thread haha.. but.. problem is, if u use core specific config, it still needs the regular config, to tell it to point to the other config haha.. kinda redundant.. but.. if u use mine, its universal to each of the cores lol..

  • Thanks 1

Share this post


Link to post
Share on other sites

Thx a lot Felida! Testing as we speak.

 

BTW off topic: Would be too much effort to compile some of the fixes in newer Mame 2003 cores to xbox 360? Or are we tied to the Libretro guys and their releases?

 

EDIT: YAY! It saves screen custom size and the gamma corrections look GREAT! 

 

It just doesnt save the button configs. Do I have to edit the .ini or the .cfg file? 

Share this post


Link to post
Share on other sites
1 hour ago, MKK hanzo said:

Thx a lot Felida! Testing as we speak.

 

BTW off topic: Would be too much effort to compile some of the fixes in newer Mame 2003 cores to xbox 360? Or are we tied to the Libretro guys and their releases?

 

EDIT: YAY! It saves screen custom size and the gamma corrections look GREAT! 

 

It just doesnt save the button configs. Do I have to edit the .ini or the .cfg file? 

If you have the emulator source, then yeah.. as the source code for this version is available.. shouldnt be hard.. 

 

The config saves when you legitly press the exit button within the menu.. its weird honestly haha.. if you use the guide to go back to dash, it doesnt save.. 

 

This was also the issue i found, for saving the game saves, i changed a setting that saves constantly instead, so even if you use the guide, your game does save normal..

 

Now, gamma corrections?? Or do you mean shaders?? Haha..

 

Share this post


Link to post
Share on other sites
On 25/2/2018 at 5:14 PM, felida said:

If you have the emulator source, then yeah.. as the source code for this version is available.. shouldnt be hard.. 

 

The config saves when you legitly press the exit button within the menu.. its weird honestly haha.. if you use the guide to go back to dash, it doesnt save.. 

 

This was also the issue i found, for saving the game saves, i changed a setting that saves constantly instead, so even if you use the guide, your game does save normal..

 

Now, gamma corrections?? Or do you mean shaders?? Haha..

 Awesome Felida! Thanks for the answer! 

 

I meant by Gamma corrections that the default configs have the games TOO bright! With your cfg, tjey look awesome.

I also asked if this specific fix could be ported into the already sxisting Retroarch MAME 360 core:

https://www.libretro.com/index.php/retroarch-1-6-4-released/

 

Quote

MAME 2003 – DCS sound issues fixed! Proper sound now in Mortal Kombat/NBA Jam/WWF Wrestlemania!

mk3_a.png
For a long time, the MAME 2003 core has suffered from an issue where the sound could deteroriate after a couple of minutes for about 30 seconds before restoring itself. This would happen in Midway DCS-based games such as Mortal Kombat 1/2/3/Ultimate, NBA Jam, etc.

A bounty had been submitted by dankcushions some time ago and finally this bounty is on the verge of being completed! It should finally be possible to play these games at fullspeed on something as low-fi as a Raspberry Pi without being put out of the game by sound bugs and being reminded you are running an inaccurate emulated version of the game.

This is just the fix for the DCS using gaes (Mortal Kombat 3 is the most needed IMO). 

 

Thanks in advance!!!!! (I can test)

Share this post


Link to post
Share on other sites
8 minutes ago, MKK hanzo said:

 Awesome Felida! Thanks for the answer! 

 

I meant by Gamma corrections that the default configs have the games TOO bright! With your cfg, tjey look awesome.

I also asked if this specific fix could be ported into the already sxisting Retroarch MAME 360 core:

https://www.libretro.com/index.php/retroarch-1-6-4-released/

 

This is just the fix for the DCS using gaes (Mortal Kombat 3 is the most needed IMO). 

 

Thanks in advance!!!!! (I can test)

I will build in next day or so.. its easy.. yeah the gamma correction was set to on in default, its off in my config, as well as shaders are enabled by default in my config lol.. so that probably makes it look smoother and whatnot as well..

Share this post


Link to post
Share on other sites
23 minutes ago, felida said:

I will build in next day or so.. its easy.. yeah the gamma correction was set to on in default, its off in my config, as well as shaders are enabled by default in my config lol.. so that probably makes it look smoother and whatnot as well..

 Really appreciated! I have always dreamt of building my custom multi Mortal Kombat arcade cabinet. I used to have all 4 boards but due to me moving to another country, I had to sell out my collections :(  Including tghe full USA Castlevania games and a beefy MK collection. 

DSC07559.jpgl

 

 I have also setup my classic Xbox with MANY MK games (Im a sick fan) but sadly, Old Xbox XANT cope with UMK3, MK4 (at least psx versions) and many more =( 

 having them on Xbox 360 at least I would add MK vs DC and MK 2013!
 

 

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, MKK hanzo said:

 Really appreciated! I have always dreamt of building my custom multi Mortal Kombat arcade cabinet. I used to have all 4 boards but due to me moving to another country, I had to sell out my collections :(  Including tghe full USA Castlevania games and a beefy MK collection. 

try this build mate, its got the sound fix included:

https://mega.nz/#!2EIExJiY!yxl9WgRiq3xkruXafv5AsSCKT4Ydpq4HalUEdFxE-0k

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, felida said:

try this build mate, its got the sound fix included:

https://mega.nz/#!2EIExJiY!yxl9WgRiq3xkruXafv5AsSCKT4Ydpq4HalUEdFxE-0k

Downloading! I will post up ASAP! 

THANKS!

 

HAPPIEST EDIT EVER:

I just CANT believe it! Corrupted sound after 4 fights is FIXED!!!!!!!! YAY!!!!!!!!!!

Recording a walkthrough in UMK3 just to celebrate and uploading to YT!!!!

T H A N K S  F E L I D A!!!!!!!!!! 

 

(This should be the default core on MAME now IMO)

Share this post


Link to post
Share on other sites
57 minutes ago, MKK hanzo said:

Downloading! I will post up ASAP! 

THANKS!

 

HAPPIEST EDIT EVER:

I just CANT believe it! Corrupted sound after 4 fights is FIXED!!!!!!!! YAY!!!!!!!!!!

Recording a walkthrough in UMK3 just to celebrate and uploading to YT!!!!

T H A N K S  F E L I D A!!!!!!!!!! 

 

(This should be the default core on MAME now IMO)

well since it works.. an admin could post it to 1st post here.. lol.. i dont care.. as i am completely open to it..

and you're welcome.. i didnt know if it would work.. had to do some trial and error to compile it.. as there was something in the code that didnt match up, removed that and it compiled nicely.. glad it works well for ya

  • Like 2

Share this post


Link to post
Share on other sites

Encountered some issues and im reporting. 

 

 After exiting the game correctly, it creates (in this case UMK3.cfg) a .cfg file for that game.

Now if i load the rom again, it gives me a FATAL CRASH ERROR. 

Funnily, the buttons I assigned to MENU, COINS and RESET under the mame GENERAL CONFIG are saved and present NO issues at all. 

To correct this, I just delete umk3.cfg and the game loads again. I just have to exit the emu/game via the Xbox guide button, so it does NOT creates an .cfg for that game. 

ITS OK FOR ME, but for some it can be bothersome. 

 

I overcame the button assignment by re binding on the RA menu and save them. 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, MKK hanzo said:

Encountered some issues and im reporting. 

 

 After exiting the game correctly, it creates (in this case UMK3.cfg) a .cfg file for that game.

Now if i load the rom again, it gives me a FATAL CRASH ERROR. 

Funnily, the buttons I assigned to MENU, COINS and RESET under the mame GENERAL CONFIG are saved and present NO issues at all. 

To correct this, I just delete umk3.cfg and the game loads again. I just have to exit the emu/game via the Xbox guide button, so it does NOT creates an .cfg for that game. 

ITS OK FOR ME, but for some it can be bothersome. 

 

I overcame the button assignment by re binding on the RA menu and save them. 

 

 

Umk3.cfg shouldnt be created.. post that config and let me have a look.. as well as the retroarch config.. i didnt change anything withing retroarch, except the dsp patch.. which is osd.h.. 

Share this post


Link to post
Share on other sites
4 hours ago, MKK hanzo said:

delete default.xex.cfg

as that isnt needed at all nor know why it was there lol..

BUT, try this build.. see if it works, and doesnt create excess configs for no reason:

https://mega.nz/#!zEAQxRpT!h2z2iwXwBeEpQ0JC7NogCRREsc_dP-bzO_c9xnQ61cs

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 1/3/2018 at 2:02 AM, felida said:

delete default.xex.cfg

as that isnt needed at all nor know why it was there lol..

BUT, try this build.. see if it works, and doesnt create excess configs for no reason:

https://mega.nz/#!zEAQxRpT!h2z2iwXwBeEpQ0JC7NogCRREsc_dP-bzO_c9xnQ61cs

 Working AWESOME dude! It does NOT creates any game .cfg anymore and there have been NO fatal crashes ATM. Still testing!!

Thanks!!!

Share this post


Link to post
Share on other sites
1 hour ago, MKK hanzo said:

 Working AWESOME dude! It does NOT creates any game .cfg anymore and there have been NO fatal crashes ATM. Still testing!!

Thanks!!!

Yeah, they changed their stuff around ALOT within retroarch.. thats why it was creating random configs lol.. it was supposed to make it somewhere else(parent dir).. and since i removed that bit of code in the 1st one, they were being created in default.xex location..

 

i went thru the code, and found the fix, and just modified the original 1.0.0.3 (unofficial) to fix the sound.. and built that.. so it should be working no problem..

 

nothing else was changed but the formula that does the sound, instead of modifying the newer osd.c to use in the older version.. lol.. but 1st build was just a test build.. 2nd build is the correct one.. 

 

Now i know why swizzy said it was a pain to do up as the code is everywhere.. instead of being specific to the console you are releasing it for..

 

Granted, its better for them, since they build for different systems all at once.. but for 360 release.. their scattered code is a pain because stuff doesnt want to work properly lolol

  • Thanks 1

Share this post


Link to post
Share on other sites

Just here reporting that I have been getting a BLAST out of the RA fixes! 

 Also commenting that, in other threads here, there are requests for a Killer Instinct Emu ported for the 360, BUT, I am reading that Mame 2003 RA supports it? 

 

 Im doing some tests and will come back with results (if any). Also, it seems like it was a backport fix (what Felida did), so be on the lookout!

Share this post


Link to post
Share on other sites
On 2/28/2018 at 11:02 PM, felida said:

delete default.xex.cfg

as that isnt needed at all nor know why it was there lol..

BUT, try this build.. see if it works, and doesnt create excess configs for no reason:

https://mega.nz/#!zEAQxRpT!h2z2iwXwBeEpQ0JC7NogCRREsc_dP-bzO_c9xnQ61cs

Copied Link to list of updated Aurora Retroarch Cores. Will mark as experimental, since this hasnt been tested by me. If people are happy with it in the end, I might replace integrate it into the main archive at some point, but I am lazy, so it wont be for a while. lol.

 

OP Updated.

Share this post


Link to post
Share on other sites
1 hour ago, gavin_darkglider said:

Copied Link to list of updated Aurora Retroarch Cores. Will mark as experimental, since this hasnt been tested by me. If people are happy with it in the end, I might replace integrate it into the main archive at some point, but I am lazy, so it wont be for a while. lol.

 

OP Updated.

the ONLY change of code, is the formula that does the sound:

k0rbzd.png

 

EDIT: left is original out of the source, right is the fixed code.. lol

Share this post


Link to post
Share on other sites
23 hours ago, MKK hanzo said:

Just here reporting that I have been getting a BLAST out of the RA fixes! 

 Also commenting that, in other threads here, there are requests for a Killer Instinct Emu ported for the 360, BUT, I am reading that Mame 2003 RA supports it? 

 

 Im doing some tests and will come back with results (if any). Also, it seems like it was a backport fix (what Felida did), so be on the lookout!

you COULD try and use the 1.5 chd, but again, i dunno lol.. too lazy to bust out xdk, as research says it needs it..

Share this post


Link to post
Share on other sites
On 3/7/2018 at 4:26 PM, felida said:

you COULD try and use the 1.5 chd, but again, i dunno lol.. too lazy to bust out xdk, as research says it needs it..

did anyone get killer instinct working?

Share this post


Link to post
Share on other sites
24 minutes ago, Notroubleclubber said:

anyone know how to install this on aurora please

You load it like any other game..

Share this post


Link to post
Share on other sites
On 7/25/2018 at 10:54 AM, Notroubleclubber said:

anyone know how to install this on aurora please

For the auto launch feature to work, you need it to be tagged as emulators and not games. You set this when you create the scan path.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...