Jump to content
Sign in to follow this  

FSD 3rev775 Link, weather and few other problems

Recommended Posts


Few days ago i reanimated my Xbox, change 3.5' hdd to working one and reinstalall the stuff.
FSD 3rev775, dashboard 17150, avatar update, dashlaunch 3.14, xexmenu.

It's working, but i have few problems, mostly witch internet.
How it looks.
When i installed fsd 3rev735, it couldn't download update info and connect to LINK, but game covers an TU worked. I had covers, fsd said there is no TU for BlazBlue and my router was telling me that (which is my Xbox IP addres) was downloading things.

Then, i updated Dashboard to 17150 with my 3.5' hdd unplugged. After that, i tested internet connection through NXE, and it connected to the internet (i stop the test before connecting to xbox live, so i hope i'm not banned).
After plugging HDD and starting FSD, i could not more pass the NXE connection test.
So i think this is good. Xbox have internet connection, but FSD blocked it to prevent banning my console.

In FSD things looks the same as before. I can download cover for BlazBlue, check TU, but not download the update info, nor connect to LINK.

I have uPnP and DMZ enabled in my router, integrate xbox mac adres with IP, forwarded 3071, 3072 and all other xbox live ports to 3071, 3072 and all others xbox live ports. 
On xbox i have set everything to automatic, cause when i set up something manual it stops working.
My DNS servers are (my router IP).
In dashlaunch i tried few network settings combinatios (even ublocking Xbox DNS) and no one were working.
I and the internet are out of ideas, so i'm asking you for help.
I have Huwaei CPE B593 LTE router.

Second thing.
I really like weather add-on, but i can't force it to work.
I found that normally is not working cause some shit with WorldWeather, but you can change original fsd Api key with your Api key.
It should be somewhere in default.xex from fsd, but i encrypted it, open with hex editor and could't find it.
Could someone help me with that?

And to straight things, fsd weather should works like:
1. Go to worldweather, sign up and get you free api key. With out any information about you location, town or place you want to check weather.
2. In fsd weather setting menu, type you Api key in api key place, then write your town and press check.
3. Now, fsd should find your town, and weather and everyone should be happy.

Am I right?

Now the content paths problem.
I set up them in menu, assigning xbox 360 with xbox 360 folder, homebrew with homebrew folder and so one.
And now my fsd is finding snes360 (which is in emulator folder) in homebrew tab. And i don't know why.
Maybe is the depth scan problem. I set it to 5, cause on 2 fsd could not find dashlaunch, but i don't know how depth is working,
and can't simply undo changes.
Could someone help me with this or explain how it works? (i assume that depth level say how much folders in folders should fsd check for xex files, but i'm not sure).

I will be thankful for any help with any of this things. I think i will post few more problems in future, cause i like when everything is working, even if i'm not really using it :)

Share this post

Link to post
Share on other sites

FSD doesn't block internet, LTE routers (4G) don't really support portforwarding, so i'd assume this is where the problem with LiNK is at... the problem with Update info is caused by the server not being the same as it used to be... so... it can't download something that doesn't exist anymore...

Your APIKey is part of the database, so open those and change it there... other then that, yeah it seems like you understand what to do to get the weather stuff working...

About SNES360 -> just move the game using the menu settings for that :)

The depth is as you've guessed how deep it should scan for default.xex etc.

Share this post

Link to post
Share on other sites

So, in NXE i should connect to the internet, right?

Server is diffrent, or it's deleted? Can i fix it in fsd files?

which database? This in fsd folder? With two files, content and settings? I could not find there api key. I was opening this with wordpad nad hex editor.

So i'm fucked up because of my router, and i can't really do much about it? 



Ok, i opened it with some db browser but it have right Api key, the problem is my connection to the internet

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...