Jump to content
RealModScene
Nachtgarm

System Link UDP/TCP fail despite open ports

Recommended Posts

Hi everyone,

I've seen a few similar threads, but none of them described my problem, or solved it. Therefore I open a new topic:

Problem:

I can't get a "pass" on TCP/UDP.

-------------------------------------------------------------------------------------------------------------

Description:

I would like to play online with my RGH Xbox via System Link, but can't get a "pass" on the port tests. I am able to connect to "rooms" via System Link, but no games are found.

-------------------------------------------------------------------------------------------------------------

Games tested:

Diablo 3 UEE (RF, latest TU), CoD Modern Warfare 2

-------------------------------------------------------------------------------------------------------------

Setup:

- XBOX 360, Jasper, Glitch2, FSD 3 Rev 775, Dashlaunch 3.10, Kernel 2.0.16537.0, Skin: The Dream Theme 2.5

- Router: Fritz Box 7630

- ISP: Willy.Tel (FTTB)

-------------------------------------------------------------------------------------------------------------

Network Settings in NXE:

- Manual Settings

- Static IP: 192.168.178.66 (DHCP reserved IP for XBOX on MAC)

- Subnet Mask: 255.255.255.0

- Default Gateway: 192.168.178.1 (IP of my Router)

- Primary DNS: 192.168.178.1

- Secondary DNS: 192.68.178.1

-------------------------------------------------------------------------------------------------------------

Dashlaunch Settings:

[Paths]

Default = Hdd:\Apps\FreeStyle\default.xex

[Plugins]

plugin1 =

plugin2 =

plugin3 =

plugin4 =

plugin5 =

[Externals]

ftpserv = false

ftpport = 21

updserv = false

calaunch = false

fahrenheit = false

[settings]

nxemini = true

pingpatch = true

contpatch = false

fatalfreeze = false

fatalreboot = false

safereboot = true

regionspoof = false

region = 0x7fff

dvdexitdash = false

xblaexitdash = false

nosysexit = false

nohud = false

noupdater = true

debugout = true

exchandler = true

liveblock = true

livestrong = false

remotenxe = false

hddalive = false

hddtimer = 210

signnotice = false

autoshut = false

autooff = false

xhttp = true

tempbcast = false

temptime = 10

tempport = 7030

sockpatch = false

passlaunch = false

fakelive = false

nonetstore = true

shuttemps = false

devprof = false

devlink = false

autoswap = false

nohealth = true

nooobe = true

autofake = false

-------------------------------------------------------------------------------------------------------------

LiNK Settings (FSD):

Enable LiNK ✔

Enable UPnP ✔

Data Port: 3072

Broadcast Port: 3071

Status: FSD Plugin is Loaded || ConnectX Plugin is not Loaded...

-------------------------------------------------------------------------------------------------------------

Router Settings:

UPnP enabled ✔

List of UPnP enabled Ports:

Protocol     Port       Host                 IP-Address            to Port

TCP          3072         RGHXBOX        192.168.178.66      3072

TCP          3072         RGHXBOX        192.168.178.66      3072

UDP          3071         RGHXBOX        192.168.178.66      3071

UDP          3071         RGHXBOX        192.168.178.66      3071

Port Forwarding: Exposed Host for RGHXBOX (192.168.178.66)

Additional Router Info:

There is no DMZ Option available

There is no NAT Settings Option available (see above: Exposed Host)

-------------------------------------------------------------------------------------------------------------

Result of Test in FSD:

UPnP Status: UPnP enabled Router Found

Data Port Status: Port: 3072 TCP: Fail UDP: Fail

Broadcast Port Status: Port 3071 TCP: Fail UDP: Fail

JQE360 Authentication Status: Auth [username]: Pass

DevLink Disabled: Pass: DevLink is disabled

Ping Patch Enabled: Pass: Ping Patch enabled

-------------------------------------------------------------------------------------------------------------

Additional Info:

I have already tried setting the Router to non DHCP which had the same result.

Changing the ports in the Router and in FSD had the same result.

-------------------------------------------------------------------------------------------------------------

That should be it... I hope I haven't forgotten anything and hopefully someone can help me with this issue.

Thx in advance and Cheers :)

Nachtgarm

Share this post


Link to post
Share on other sites

I'd recommend setting your Xbox 360 settings to Automatic, and having your router set the settings with Reserved DHCP (which you already have) that way your network settings on the box won't be an issue, it's likely an issue with your DNS settings

Not sure what type of connection you have, but if your connection type is behind a ISP level NAT, you can't use LiNK because your ISP have a router infront of your router which doesn't have the ports open, and they most likely won't help you with it etheir...

Share this post


Link to post
Share on other sites

Thx for the fast reply!
I already had the settings in NXE on automatic before (forgot to mention that).

I had high hopes, that this won't be the case: " [...] but if your connection type is behind a ISP level NAT, you can't use LiNK because your ISP have a router infront of your router which doesn't have the ports open [...], but as it looks like I have to call my ISP and ask for that...

I'll keep you posted! At least it is not my fault, due to obvious erroneous settings ;)

Cheers

Share this post


Link to post
Share on other sites

Your port setting was wrong,, so u need to change like this

3071 all(TCP/UDP) your Xbox ip

3072 all(TCP/UDP) your Xbox ip

Sent from my ST23i using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Oh yes, now that i checked it closer i see it also...

You need to have TCP and UDP on both 3071 and 3072, not TCP on 3072 and UDP on 3071

Share this post


Link to post
Share on other sites

Sorry guys.... That is a typo! Of course the port forwarding is set to

TCP          3072         RGHXBOX        192.168.178.66      3072
TCP          3071         RGHXBOX        192.168.178.66      3071
UDP          3072         RGHXBOX        192.168.178.66      3072
UDP          3071         RGHXBOX        192.168.178.66      3071

and besides that I've just called my ISP and found the problem: I'm connected via FTTB with a SIngle dynamic IP v6 Tunnel. Therefore the IP v4 forwarding isn't working.... They promised, that they will change my connection to dual tunneling, so that my XBOX with IP v4 is reachable through the port forwarding.

  • Like 3

Share this post


Link to post
Share on other sites

Sorry guys.... That is a typo! Of course the port forwarding is set to

TCP          3072         RGHXBOX        192.168.178.66      3072

TCP          3071         RGHXBOX        192.168.178.66      3071

UDP          3072         RGHXBOX        192.168.178.66      3072

UDP          3071         RGHXBOX        192.168.178.66      3071

and besides that I've just called my ISP and ofund the problem: I'm connected via FTTB with a SIngle dynamic IP v6 Tunnel. Therefore the IP v4 forwarding isn't working.... They promised, that they will change my connection to dual tunneling.

hopefully that'll make it work properly

Share this post


Link to post
Share on other sites

I'll keep you posted, just in case anybody has the same problem

It is the same problem that I have, and change internet provider, I can connect to JQ360 but I can not see the games

Share this post


Link to post
Share on other sites

It is the same problem that I have, and change internet provider, I can connect to JQ360 but I can not see the games

I can download TU and covers, I connect to system link, but on entering the games do not appear interconnection please help me...  cheers

Share this post


Link to post
Share on other sites

hello, i've enabled upnp for port mapping and i've enabled the upnp checkbox in the router page. and it still not working i cant click on system link

Share this post


Link to post
Share on other sites

hello, i've enabled upnp for port mapping and i've enabled the upnp checkbox in the router page. and it still not working i cant click on system link

If system link is greyed out, it's because it's a incompatible game or your console doesn't download the list of compatible games properly, the solution is to check if the game is compatible or not followed by deleting the Plugins\Data folder if the game is indeed compatible

Share this post


Link to post
Share on other sites

This means maybe your device don't open the ports, or your ISP is blocking them...

It can also be related to xhttp being disabled...

Share this post


Link to post
Share on other sites

This means maybe your device don't open the ports, or your ISP is blocking them...

It can also be related to xhttp being disabled...

xhttp is enabled

Share this post


Link to post
Share on other sites

same problem guyz, but maybe i should call my isp provider, maybe there is really a router infront of my router, because same internet line comes and connects all routers of my apartment, thanx and pray that would help.

Share this post


Link to post
Share on other sites

same problem guyz, but maybe i should call my isp provider, maybe there is really a router infront of my router, because same internet line comes and connects all routers of my apartment, thanx and pray that would help.

You have multiple routers?

Share this post


Link to post
Share on other sites

hey i tried to link on my huawei HG8247H but says tcp pass udp fail. i tried doing udp/tcp on both but not working.Pls help...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...