Jump to content

Can't download TitleUpdates: Error 7B

Recommended Posts


I just got FSD3 a few days ago. Today, I tried to download Title Updates, but it fails for every game. The log reads:

19:51:41.570|TUDownloadManager|F9000034|Reading List for TitleID [55530848]

19:51:41.570|TUDownloadManager|F9000034|Downloading Title Updates for TitleID [55530848]

19:51:41.570|TUDownloadManager|F9000034|Process as Media Match 0251DC2D : 0251DC2D

19:51:41.572|TUDownloadManager|F9000034|DataPath : [game:dataTitleUpdatesE209B76669B5CACCB9FBDF995AA7D6D1BEE62D2F_USBMUC]

19:51:41.572|TUDownloadManager|F9000034|Saving Title Update to [game:dataTitleUpdatesE209B76669B5CACCB9FBDF995AA7D6D1BEE62D2F_USBMUCTU_1AL6228_0000004000000.0000000000081]

19:51:41.572|TUDownloadManager|F9000034|Starting Download

19:51:41.572|HTTPDownload|F9000034|Queue Size: 2

19:51:42.045|HttItem|F9000034|Create File Failed: Error Code: 7B

19:51:44.218|TUDownloadManager|F9000034|Clearing TtileID

19:51:44.218|TUDownloadManager|F9000034|Clearing Mediaid

19:51:44.218|TUDownloadManager|F9000034|Clearing Gametype

19:51:44.218|TUDownloadManager|F9000034|Clearing downloadqueu

19:51:44.218|TUDownloadManager|F9000034|Notify Requester

I then tried to create the folder E209B76669B5CACCB9FBDF995AA7D6D1BEE62D2F_USBMUC (which doesn't exist) under "game:dataTitleUpdates" myself, which also results in an "Copy Failed with Error: 7B".

What does this error mean? Is there a way to fix it?



*edit: I just tried it again, I can create "E209B76669B5CACCB9FBDF995AA7D6D1BEE62DF_US", but not "E209B76669B5CACCB9FBDF995AA7D6D1BEE62DF_USB", maybe the dirname is too long (Windows Explorer shows something like "Invalid Access Number" when I try to rename it via SMB). How can I change the path to something shorter?

*edit2: According to the log, the serial of the device is without the _USBMUC, and this would be short enough. Why is USBMUC added?

21:16:27.964|DrivesManager|F9000000|Mounting Results: ??Usb0:, DeviceMass0 - serial: E209B76669B5CACCB9FBDF995AA7D6D1BEE62D2F - DeviceId: 00000001

Share this post

Link to post
Share on other sites

USBMUC is added because the serial without it refers to the USB device itself, so if we didn't add it then there would be 2 drives with the same serial.

I will look into lengths and find a way to shorten it for next rev.

Share this post

Link to post
Share on other sites

Okay thanks :)

I found a way to avoid the error for the meantime: I added an extra line to the table "TitleUpdatePaths" in the database without _USBMUC on the DeviceID/Path, and now I get asked whether I want to save it on USB0 or USB0MUC (USB0MUC gets added to the DB on reboot). When selecting USB0 downloading and using title updates works fine.

Share this post

Link to post
Share on other sites

Okay, I just got a game which actually shows it version number and I have to say the "workaround" is not working. Title Updates are are downloaded but not loaded/injected into the game :( Are there any plans for a date when a fixed version might be released? This bug is really annoying...



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...