Jump to content
RealModScene
a_netanel

"Could not start" error running extracted games from external HDD

Recommended Posts

Hi all,

 

I have a problem that bugs me for a while.

I'm running the latest dashlaunch and the latest F3 on my jasper RGH box (insalled it yesterday).

I have an external HDD (Iomega 1TB eGo USB 3.0) which is formatted properly to fat32 and is viewable in the dash.

 

The problem is that games that are extracted to this USB HDD, whether with the "Extract DVD" option in the dash, or with Xbox Image Browser from my PC, don't work.

When trying to run the default.xex file (from the Game Library, file explorer, or even from Dashlaunch), the infamous "The game couldn't start. Try downloading the game again." error appears, and I'm kicked out to NXE.

The funny thing is that games in GOD format run perfect from the USB HDD. (So its not that the USB HDD is not working)

Another thing, if i copy the folder of the extracted game to the internal HDD, it works! (So its not a problem of corrupted files)

Another (Another :) ) thing, When I used a smaller, 16 GB USB thumb drive, I'm able to run games. Both extracted and GOD. (So its not that USB extracted gamed does not work at all)

 

I tried searching the net and this forum, but could not find an answer.

 

Thanks guys :)

Share this post


Link to post
Share on other sites

Try running the game through x360GameHack to remove any AP Protection.

 

Also, if you ahve the disc, why not install the game to hard drive in NXE and use NXE2GOD to convert it. Should resolve this issue?

 

Another thing, make sure you use the USB at the back, as the back USB Ports have their own dedicated SystemBus, where as the 2 at the front share one systembus amongst other things on the board.

  • Like 1

Share this post


Link to post
Share on other sites

@irishdave

Thanks for your reply.

I'm not familiar with x360GameHack. I'll definitely look into it.

 

during my troubleshooting I did exactly what you suggested and used NXE2GOD. This method works, but it means that I need to first copy the game with NXE, convert with NXE2GOD, find the string that is the game folder, and finally copy it again from the internal to the external HDD. Possible, but cumbersome. It also causes the game description to get lost and changed to something like "this is a copied game insert the disc to play" (I'm at work now, so I can't remember the exact string). Finally, The whole point was to use extracted format rather than GOD :)

 

I think that in a past troubleshooting session I did try to run the HDD through the back ports, but I will try again, since I upgraded the software since.

 

Thanks again :)

Share this post


Link to post
Share on other sites

Send me a message and I'll pop it over to you.

 

If your able to copy the game with nxe and convert it, this is the best method in my experience, especially with kinect games. Kinect games don't always work when you convert them on the PC to GoD but worked for me with no issues what so ever.

 

I understand what you mean to use extracted why tho if you dont mind me asking, GoD format can be as little as 60 files, extracted format can have 1000s of files for the HDD to index?

 

 

I'll send u over the x360gamehack and you can try it and let me know.

 

 

Can I presume your hard drive (good brand btw) uses 1 USB and has an external power supply?

 

One more method, install to HDD in NXE, convert to GoD, download to PC, convert GoD2ISO, use xbox image browser to extract data. Re upload the extracted Data. LOL... Its long method you could try

Edited by irishdave

Share this post


Link to post
Share on other sites

Well, I don't have Kinect yet, and would probably never have, but your point is taken.

I have no good reason for preferring extracted over GOD. I did read somewhere that there are advantages for extracted when using all kinds of MODs, but I'm not really into that. My main reason is the ease of conversion. I have quite a few games in DVD form, without the ISO. Extracting directly from FSD is the easiest way to get them on a HDD. I cases where I have the ISO I don't mind using ISO2GOD.

That, and the fact that an unsolved technical problem can drive my mad. I hate workarounds... :p

 

The USB HDD is a portable (2.5") one, without a power brick. It has a split cable, for cases where the host device can't supply enough power, but I don't think that is the case. The HDD is spinning and is readable and writable.

 

And yeah, as an EMC employee (Owner of Iomega) I must agree :D

 

(Not sure what you meant by "pop it over"... my English isn't bad, but I'm a bit rough on slang ;) I found the x360GameHack software, if you meant that.. )

Share this post


Link to post
Share on other sites

Mods can be a fun thing, especially with sand box games like Minecraft and Just Cause 2, the only problem is they're mostly PC mods and not all of them work on the 360.

 

Try running the default.xex through the X360gamehack then see if you get the issues still before attempting anything else, you may need to tick 1 box everytime "Make Retail" instead of "Make Devkit"

 

Split USB, just make sure they're using the back USB ports, and in the launch.ini have "hddalive = true" and "hddtimer = 210" to prevent the hard drive going to sleep especially when in game mode. Yes, hard drives can still sleep when playing the game from it as the game is loaded and only uses the hard drive when loading new missions/maps.

 

Just wondering, why don't you replace the internal hard drive with the bigger one, have it directly powered by the internal xbox, might solve your problem this way.

 

All my games are GoD, simply because having them as extracted would round up to be about 700,000 files for the xbox to index, where-as now I've only got 6,272 files. Having too many files could slow down the USB drive and giving you "can't load game" issues.

Share this post


Link to post
Share on other sites

I think I can safely conclude that the problem is with my USB HDD.

 

I updated my kernel, reinstalled dashlaunch and the official dash, and nada. (I had hopes for that : )

Tried to use X360gamehack, and nada.

Tried to use the back USB ports. nada.

Then I tested an old, 64GB USB HDD and lo and behold - everything is working just fine.

 

The last nail was that in the Storage settings in NXE, when trying to configure my USB HDD, it fails. But the older USB HDD is able to go through the configuration just fine.

I guess I'm in the market now for a new (or old) HDD. Maybe I'll take on the advice given here and simply upgrade the internal HDD.

 

This sucks, but at least I know now where the problem resides. Even if not exactly what it is.

 

Thanks guys.

Share this post


Link to post
Share on other sites

LOL, just upgrade the Internal HDD then you'll have no additional hardware sitting outside. Besides, you could sell the official hdd to make up some of the cost if not, most :)

Share this post


Link to post
Share on other sites

I had a similar problem that extracted games won't run without theerror. They work fine with the FSD 2.2+ and Xexmenu so I know my HDD isfine as well as the rips. It's definitely a bug in FSD 3.0 that needs tobe fixed. There haven't been any updates to it for a while now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×