Jump to content

GaDaBaMa 2.2.1 FINAL for FSD2

Recommended Posts

Posted Image



Although LAN is supported I don't recommend migrating over LAN. It's very slow.

Tip: copy your FSD2/F3 folder to a USB stick.


Make sure your locale settings are set to english or another western european language

Posted Image

Otherwise your .assets files might be faulty.


Reorganizing your database consists of many steps:

  • Backup fsd2data.db -> fsd2data.backup
  • Import fsd2data.db
  • Alter ContentItems table -> new IDs
  • Alter Assets table with new paths
  • Alter Favorites, UserRatings with new ContentIDs
  • Change foldernames -> local and remote (GameData)
  • Delete folders that are not used in the database
  • Delete all records from RecentlyPlayed table
  • Clean up / delete tmp tables / Vacuum / Integrity check / Dump database (as long as Vacuum doesnt work over Samba)
  • Rescan JPG subfolders for GaDaBaMa
Until STEP5 you can still recover your database. Just rename fsd2data.backup to fsd2data.db if GaDaBaMa cannot recover it automatically. After STEP5 your folder names will change to their new IDs. This means that even if you recover your database all folder names will possibly be wrong.

Your GameData folder will not get backed up during this process. Do it manually or risk it. This function is part of this app because it works fine on my system. Can't guarantee it for yours. You have been warned.


Since GaDaBaMa 2.1 you need to disable this feature on the database you wish to sync and to enable it in another FSD2 application you use to connect with GaDaBaMa. Under Settings, enable Samba server.

If you’re successful, you’ll see clients connected: 1.

  • FSD2 App with all your content -> Samba disabled
  • FSD2 App – called Samba App -> Samba enabled

    (new install without

    scanpaths, games etc.)

Each time you wish to sync GaDaBaMa with your main FSD2 database you must enter your Samba App. This is done to prevent random errors while reading/writing the database. Of course if you connect your Xbox360 HDD through USB/eSATA you don’t need a Samba App, but you must disable Samba on your FSD2 App as it performs the check either way.





2.2.1 FINAL

-Fixed You must run this application as Administrator bug (useless Silverlight reference accidentally set)


-Added checks when renaming folders (RODB)

-Added TreeView

-Added add current game to syncQueue -> manual editing

-Added create .assets file for F3 -> manual editing

-Added Migrate FSD2 to F3

-Added Google Translator language! Use the form to translate the GUI into your language


-Added missing settings when updating GaDaBaMa

-Added SyncQueue feature

-Added alternative TitleId Marketplace search

-Added Reorganize database feature

-STEP2/3/4 code partially rewritten

-Fixed Slideshow


-Added ActiveX wmp.dll to references

-Changed Path for TitleUpdates when downloading & uploading


Setup registers MSCOMCTL.OCX


-Fixed Homebrew/Emulator names/description etc. issue


=====Title Updates=====

-Changed TitleUpdates: link between tables from filename to hash.

-Changed TitleUpdates: form filter on start: show only max(version) of game mediaid. Filter off = show all

-Fixed hex(MediaId) conversion. Ex: New 05438F06 instead of 5438F06


-Added Mouse wheel support to Mainform

-Added function/Shortkey N: Navigate to record

-Added New Coverflow (Shortkey C). Mouse wheel/keyboard support. Press Enter/C key or double-click to select

-Added GameWall (Shortkey W). Mouse wheel/keyboard support. Double-click to select

-Added Highslide function to Avatar form (click to activate)

-Fixed error in Avatar function (no items found)

-Fixed err2165 on Avatar/Alphabetic


-Fixed lost focus on JQE360 current Game download

-Added jqe360.com download settings


-Fixed error GetContentForCurrentGame when having Alphabetic filter set with only 1 game (changing Game name)

-Fixed typo in function producing unexpected results -> images were not downloaded, wrong folder etc.

-Added xbox.com download settings



-Added SyncExpress function

-Added ContentItemTab sync Step2/4 (changing itemtab (STEP3) updates itemtab in sync process (STEP2/4))


-Added Set as Desktop Background function for Background & Screenshots

-Added On Error Handler in all functions

-Added Avatar gender settings

-Added random enabled Themes (only selected themes are randomizable)

-Fixed Err 0 in Bug Report

-Fixed Some bugs I came across


GaDaBaMa offers an alternate method to manage your FSD2 database and to migrate your FSD2 database to F3.

Data functions

  • Import/Export fsd2data.db (fsd2settings.db) (FSD2)
  • Import dlc_report.txt/gameSave_report.txt (XM360)
  • Scan Content folder for dlc/gamesaves (x360pkgtool.exe)
  • Export dlc_titles.txt (XM360)
  • Reorganize database
  • Migrate from FSD2 to F3
Online functions
  • Get Game/DLC info/images from xbox.com
  • Get boxarts/covers from covers.jqe360.com
  • Get title updates from marketplace.jqe360.com
Picture functions
  • Convert dds to jpg (irfanview)
  • Convert jpg to dds (nvdxt)
  • Convert png to dds to blobs (only for icons)
  • Create F3 .assets file
Video functions
  • Stream preview video (if available)
GUI functions
  • Coverflow
  • GameWall
  • Customized themes
  • Filter fields (alphabetic/genre/tabs)
  • Multilanguage thanks to all translators! + Google Translator
  • RSS feed
  • Screenshots Slideshow
  • Search field
  • ShortKeys
Use with caution!

GaDaBaMa syncs with following apps:

  • FSD2 RC 2.2rev1072
  • F3 rev058
  • XM360 2.0d (optional - use x360pkgtool.exe to scan Contents directly)
Please make sure you have these versions installed.

GaDaBaMa modifies fsd2data.db directly. This means

  • No fsd2data.db backup will be created
  • A faulty fsd2data.db can cause FSD2 to crash and even prevent restarting
Please make sure you have a backup plan to access your console (over FTP), in case something happens.


  • GaDaBaMa DEV (GoodfellaKeyser)
  • dhSQLite (Olaf Schmidt)
  • IrfanView (Irfan Skiljan)
  • x360pkgtool (xorloser)
  • JQE360 (JQE)
  • Samba Team
  • TeamFSD
  • XM360 (node21)
  • ctm555 Swedish translation
  • darkmurf betatester, themes creator
  • GabLeRoux French translation
  • jappi88 Dutch translation
  • JaRaBcN betatester & Spanish translation
  • Jorge Carvalho Portuguese translation
  • Kysshin French translation
  • MADOFOCS betatester & German translation
  • MeLoS italian translation
  • robins Chinese translation
  • threesixtyuser Dutch translation
  • ZoMBYaKa Russian translation
Thanks to all TeamFSD forum members and bug reporters!

Special thanks to darkmurf.


  • Like 2

Share this post

Link to post
Share on other sites

I'm a bit in the dark here. Maybe someone can shed some light:

Vacuum on local database works. File gets smaller..

Vacuum on mapped network drive works too, but file size doesn't change a bit.

I'm not even using the database while vacuuming - I'm on a second FSD2 install.

This is very strange. The same database can be vacuumed locally.

Pragma integrity_check is positive btw. Reindexing works as well.

As it is now, the database keeps growing with each SyncQueue/Reorganize DB.

As Plan B it does now a .dump database to shrink its file size to normal again.

It's not an elegant solution as vacuuming though...

This kinda stuff happens testing things locally... well, please be patient.

There were other things that worked locally but not over Samba. As it looks

now a second FSD2 install just for syncing will be mandatory.

Share this post

Link to post
Share on other sites

Any chance to get infos about FreeStyle 3 logic?

I see that all images are gone and are packed in GameFolder.assets.

Assets table is gone as well.

ContentItems seems to be the same except for the new KinectFlag field.

Thanks guys.

Share this post

Link to post
Share on other sites

Content Assets are stored in a packed binary now. We use the head to defne what offsets each art asset is at and how long it is.

the only difference in content items is the kinectflag that is correct.

You can PM me for more info, or find me on IRC.

Share this post

Link to post
Share on other sites

I took a deeper look at the assets file and this is the result:

Posted Image

Does length2 have a special meaning? Or is it always like length1? Could somebody/(JQE?) please confirm if I'm on the right path? Thanks.

Share this post

Link to post
Share on other sites

Hope this helps:



typedef struct _CONTENT_ASSET_HEADER {

DWORD Magic;

DWORD Version;

DWORD Reserved; // Future usealignment

DWORD AssetFlags;

DWORD AssetCount;

DWORD ScreenshotCount;


typedef struct _CONTENT_ASSET_ENTRY {

DWORD AssetType;

DWORD Offset;


DWORD TotalSize;



DWORD Offset;


DWORD TotalSize;

DWORD Reserved; // Future usealignment


  • Like 1

Share this post

Link to post
Share on other sites

These are the asset type ids









  • Like 1

Share this post

Link to post
Share on other sites

Nevermind. Found the problem. I was creating the assets file with a specific order but apparently it doesnt like zeros in between the assets. Everything working fine.

These are the first .assets file created through GaDaBaMa.

It includes

- Cover

- Boxart (only on SUCCESS.assets)

- Background

- Icon

- Banner

- Screenshots (16 on SUCCESS, 15 on FAIL)

SUCCESS.assets works flawlessly.

Assets flag: AF (175)

FAIL_BANNER.assets fails to show banner.

Assets flag: A7 (167)


04 00259E88 0000D3B0 0000D3B0

Bytes banner 54192 in hex d3b0

I extracted the data from 00259E88 to 001911C8

to verify if the banner is there/correct and it is.

SUCCESS.assets contains all assets. FAIL_BANNER.assets does not include boxart.

As it uses the same logic for all assets and the other file with boxart seem to work fine,

is there something special about banners? Does it matter which asset offset comes first?

Did I misunderstood the logic behind AssetFlags?

Select Case myFileName

Case "banner.dds"

AssetFlags = AssetFlags + 4

AssetCount = AssetCount + 1

Case "bg.dds"

AssetFlags = AssetFlags + 2

AssetCount = AssetCount + 1

Case "box.dds"

AssetFlags = AssetFlags + 8

AssetCount = AssetCount + 1

Case "cover.dds"

AssetFlags = AssetFlags + 128

AssetCount = AssetCount + 1

Case "icon.dds"

AssetFlags = AssetFlags + 1

AssetCount = AssetCount + 1

Case "screenshot"

SsCount = SsCount + 1

Case Else

End Select

Select Case SsCount

Case 0

Case Else

AssetFlags = AssetFlags + 32

End Select


Share this post

Link to post
Share on other sites

GaDaBaMa 2.2 FINAL released.

This is the last version for FSD2.2. Only irritating bugs will be fixed.

Otherwise consider this FINAL.

Share this post

Link to post
Share on other sites

hi Keyser,

thank you very much for your awesome apps :D its just epic , i got a problem with later GaDaBaMa release ver 2 above,

when im done installing it and open it , this error keep appearing then the program close itself , here some screenshot


im using windows 7 ultimate 32bit

i got installed :


M$ Visual C++ 2005, 2008 , 2010

M$ Office 2010 with access

but the error keep came up,

GaDaBaMa 1.2 run just fine in my sistem , im sorry if im post in wrong topic, just delete my post if it does

many thanks Keyser n RealModScene , Cheers :lol: :lol:

Share this post

Link to post
Share on other sites

Hi engagex

Thanks. This is the right topic but this error was already discussed here.

You need Access Runtime 2010 Service Pack 1

Let me know if you got it working.

  • GaDaBaMa 2.x is for FSD2. The last one (2.2.1 FINAL) has a function to migrate FSD2 to F3.
  • GaDaBaMa 3.0 for F3 will come out this weekend.

Share this post

Link to post
Share on other sites

Thanks Keyser for your reply, :)

its work now, thanks for your guidance,

im just uninnstall my office 2010, access runtime, then reinstall accesruntime 2010 and accessruntime sp1 , and its works now,

many thanks Keyser, thanks for your great work and your time

GaDaBaMa FTW, :)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...