Jump to content

fs_iso9660/updxell.bin errors on freshly compiled xell-reloaded

Recommended Posts


So I wanted to compile the latest build of xell-reloaded (commit f5006b1 on github as of today) and I did so successfully, using everything on default:

-Debian buster host machine to compile, (also tried from an old Swizzy's VM and BenMitnicK's dev VM environnement and on both xell-reloaded compiles just fine but the issues I have still happen)

-Latest libxenon grabbed from github (git clone https://github.com/Free60Project/libxenon.git commit 946f9ea) then ran "./build-xenon-toolchain toolchain" to build it. No issues there so far.

-Latest xell-reloaded grabbed from github (git clone https://github.com/Free60Project/xell-reloaded.git commit f5006b1 as mentioned earlier) and then simply ran make to build it. At first it gave me errors because there are unrecognized strings in source/lv1/startup.S apparently caused by recent changes made in the a commit to fix compilation errors when using GCC 4.9 but libxenon uses GCC 4.7.1 so I had to revert those minor changes to get it to compile properly (more details here: I simply unmade all of these changes, changing @high to @h https://github.com/Free60Project/xell-reloaded/commit/62c0bfe430c364cb0729bd0bbd4b228f2390465f#diff-12a7bfe5bade2168aa8d8f8f95fc7c27)

After that it gave me different compile errors but that's not really an issue because running "make" twice in a row builds everything properly. I assume it has to do with version.h being missing during the first run of make, but once it's created, the subsequent make compiles everything correctly. Don't quote me on that tho. It's just a wild guess, I didn't really investigate it. 

Anyways, now on to the REAL issues: 

First, whether I boot the newly compiled xell binary from XeLLLaunch or directly by flashing it makes no difference. These issues happen nonetheless. I should perhaps mention I have a RGH 1.2 Falcon. So I'm using xell-gggggg.bin (renamed to updxell.bin of course) to flash it entirely, and xell-1f.bin to launch it from XeLLLaunch. 

The issues: after it has finished initializing, xell will flood the console with "[iso9660] Error: fs_iso9660: disc is not iso9660" and "! dvd0:/updxell.bin does not have the correct size of 256kb. Aborting update!" 

Now, I obviously don't have a DVD in the drive, so this issues is weird. I tried looking in the source files but honestly I couldn't find anything relevant and attempt to find the root cause and possibly fix it. I suspect it's more a libxenon issue rather than xell-reloaded, but even after trying different (older) libxenon builds and also xell-reloaded, I couldn't get a single compiled xell that didn't produce these errors. I'm completely lost at this point lol. 

Also, another minor issue, xell no longer prints (I replaced the actual values with X's for privacy):

* MSerial: 00000000XXXXXXXXXXXXXXXX 



* Console: Falcon" 

Again, no idea why. I couldnt even find any reference to these strings in either xell or libxenon, so I don't even know how this is printed to the screen in the first place. 

Like I said, I'm complete lost at this point lol. I've been trying to find the cause and fix this for days but I didn't get anywhere. I tried compiling various builds of both libxenon and xell-reloaded to no avail. 

I attached a screenshot of the iso9660/updxell.bin error to better reflect what it actually looks like. 

I also want to make clear that I'm not looking for a workaround like disabling the DVD drive in the config.h file. I'm looking for an actual fix. Plus, that wouldn't fix the other issue of MSerial/CSerial/LDV/Console not printing anymore, so... :) 


Hopefully Swizzy or someone else capable of helping me on this is still around in this forum! :p 






Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...