Jump to content
RealModScene
that1crzywhtguy

Indie games won't work from Aurora

Recommended Posts

No matter what I try, I can't get indie (XBLIG) games to boot from Aurora. They work from the stock dash, and from dashlaunch, but not aurora. 

 

Here is my info:

I am on Aurora 0.7b r1622 located in hdd1\Aurora 0.7b.1\
I am on Kernel 2.0.17559.0, I updated my xbox before modding it;
I placed the 2.0.17559.0 update in $$ystemupdate on a USB drive in case the avatar update was the problem and no patch was applied;
I am on a Corona 4gb RGH with a 1tb internal hdd;
All games are in hdd1\Content\0000000000000000\<titleid>
All XBLIG games are in hdd1\Content\0000000000000000\584E07D2\00000002;
The XBLIG TU #29 is in hdd1\Content\0000000000000000\584E07D2\000B0000; I also placed the TU in the cache folder;
Aurora also has a copy of the TU in Aurora\Data\TitleUpdates\20200202020202(...)\584e07D2\D955ea41(...)\;
Dashlaunch is in HDD1\Dashlaunch 3.21;
launch.ini is in HDD1\launch.ini;
All XBLA and DLC unlocked in XM360v3.2d;
and all XBLIG games work in MS Dash and Dashlaunch.

Dashlaunch 3.21 settings are:
contpatch on; xblapatch on; licpatch on; pingpatch on; liveblock on; livestrong off; fakelive off; autofake on; autocont on; autofake0 0x584E07D2; (I also tried with fakelive on)

I'm going crazy over here!

 

Thanks in advance

Share this post


Link to post
Share on other sites

I run them through FSD with no problems

I tried it all through aurora reading here using the search, using google reading, and reading and reading etc..to no avail. You'll continue to go crazy trying to use aurora to run indie. They'll probably fix it through an update. At one time about 4 years ago, it was working. I havent seen anything since 

Share this post


Link to post
Share on other sites
On 6/4/2020 at 12:20 PM, that1crzywhtguy said:

No matter what I try, I can't get indie (XBLIG) games to boot from Aurora. They work from the stock dash, and from dashlaunch, but not aurora. 

 

Here is my info:

I am on Aurora 0.7b r1622 located in hdd1\Aurora 0.7b.1\
I am on Kernel 2.0.17559.0, I updated my xbox before modding it;
I placed the 2.0.17559.0 update in $$ystemupdate on a USB drive in case the avatar update was the problem and no patch was applied;
I am on a Corona 4gb RGH with a 1tb internal hdd;
All games are in hdd1\Content\0000000000000000\<titleid>
All XBLIG games are in hdd1\Content\0000000000000000\584E07D2\00000002;
The XBLIG TU #29 is in hdd1\Content\0000000000000000\584E07D2\000B0000; I also placed the TU in the cache folder;
Aurora also has a copy of the TU in Aurora\Data\TitleUpdates\20200202020202(...)\584e07D2\D955ea41(...)\;
Dashlaunch is in HDD1\Dashlaunch 3.21;
launch.ini is in HDD1\launch.ini;
All XBLA and DLC unlocked in XM360v3.2d;
and all XBLIG games work in MS Dash and Dashlaunch.

Dashlaunch 3.21 settings are:
contpatch on; xblapatch on; licpatch on; pingpatch on; liveblock on; livestrong off; fakelive off; autofake on; autocont on; autofake0 0x584E07D2; (I also tried with fakelive on)

I'm going crazy over here!

 

Thanks in advance

 

2 hours ago, games805 said:

I run them through FSD with no problems

I tried it all through aurora reading here using the search, using google reading, and reading and reading etc..to no avail. You'll continue to go crazy trying to use aurora to run indie. They'll probably fix it through an update. At one time about 4 years ago, it was working. I havent seen anything since 

In aurora they added dashlaunch options via the boot menu for games.. enabling fakelive for indie titles upon boot.. autofake only works from stock dash iirc.. I know they work from aurora without a problem.. 

 

Also, make sure you enable the TU as well, from within the indie's game options menu.. 

Share this post


Link to post
Share on other sites

I have tried to use the dashlaunch options from within aurora also, but that had no effect for me. As for enabling the TU within the indie's game options menu, when I go to title updates from within an indie, it shows no title updates to enable. This is likely the source of the problem? Why isn't it showing up there?

Share this post


Link to post
Share on other sites

I had the same problem and had to update XNA  for indie games. Found it using GOOGLE, used content manager to transfer title to xbox and now all working.

Bear in mind it is not a game title update search for XNA Title Update for Indie Games and you will find this easy enough, download, unrar and use 360 Content Manger to upload it to the xbox 360. 

Share this post


Link to post
Share on other sites

As I mentioned, I already did this. That update is right where it should be, and even tried placing it in the cache. It's in the original post.

Share this post


Link to post
Share on other sites
10 hours ago, that1crzywhtguy said:

As I mentioned, I already did this. That update is right where it should be, and even tried placing it in the cache. It's in the original post.

I had a look at my Dashlaunch which is V.3.1

contpatch - on

xblapatch - OFF

licpatch - OFF

pingpatch - on

liveblock - on

livestrong - OFF

fakelive - off

autofake - on

autocont - OFF

autofake0 to 9 ALL OFF

as you can see we have some differences in the settings and as my Indie games work in Aurora, why dont you give these settings a try to see if they work for you.

I hope they do, but if not, I am at a loss

Share this post


Link to post
Share on other sites

Tried those settings and still no dice. It's a really weird issue I'm having. 

The only difference between my setup in yours is you are on a older version of dashlaunch. 

Grrrr...

Share this post


Link to post
Share on other sites

Really is mysterious. I had an old xexmenu install disk with some apps on it to get my RGH up and running. Installed the same version of Aurora as you have but did not touch any settings in Dashlaunch as they were supposed to be the correct settings for everything to work. When I tried to play Indie games I got a message saying I needed to get title update (XNA), which I did and Voila it worked. So I am completely surprised as  to why yours in not working. Cannot see it being dashlaunch version asI had your version on an old RGH WHICH I gave to my nephew and all indie games worked on that one also.

Sorry it did not work.

Share this post


Link to post
Share on other sites

I noticed you said you placed the update on a USB in case it was the avatar update that was the problem. I remember my avatars were greyed out on main dash so applied the update to get avatars back, then applied the XNA update and that is when all Indie games worked. I assume you probably did the same as you said no patch was applied. Below is exactly what happened to me, and if your avatars are not greyed out then there must be some other hidden setting we are not getting to the bottom of. I really do hope you get this working as I feel your frustration .

I look a good puzzler now and then and this one is belter. 

 

T WORKED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

YOU HAVE TO HAVE THE AVATAR DASH UPDATE!

 

Ok, when you go to your dash, are your avatars gray? (for your profiles)

If they're gray, you need to update your avatar cache.  Without that update... Indie games will not work.  To fix this, download the .RAR file in the link.  Then, extract the contents into a folder in your USB stick and plug it into your Xbox.  Once at your Xbox, open Dashlaunch, and you're going to want to disable NOUPDATER.  Once done, save and go to Xexmenu.  In there, navigate to your USB section and open up the folder that you extracted the .RAR's contents into.  And find BiometrixSetup.xex.  Open it, and it will update your avatar cache.  Once done, your avatar should be back.  This for kernal 17150 ONLY.  Also, you HAVE to open the Indie with FreeStyle or Aurora Dash in order to bypass the stupid Xbox Live deal. 

Edit

above is a quote from somewhere but you may gather that this will be for the version of Dash you are on not the one quoted and Biometrixsetup is obviouslly the posters name for the downloaded update (I think).

 

Share this post


Link to post
Share on other sites

I never had the greyed out avatar problem. I did try to see if the update was necessary anyhow, and it didn't seem it was. 

I'm on the latest version (17559).

Share this post


Link to post
Share on other sites

Yeah, I did not think you had greyed out avatars. I am also on latest 17559 but did get the greyed out avatars .I had 3 goes at the update before it was recognised from USB in main MS dash.

Seems like you have tried everything we both can think of, and other members on the forum, without success. I can only assume it is some settings in Dashlaunch or Aurora causing the problems as your games work in both MS DASH and Dashlaunch. 

Share this post


Link to post
Share on other sites

I suspect that for some reason aurora isn't enabling the title update, and that's the problem. Now how to fix it? That I have no idea about.

Share this post


Link to post
Share on other sites
7 hours ago, that1crzywhtguy said:

I suspect that for some reason aurora isn't enabling the title update, and that's the problem. Now how to fix it? That I have no idea about.

You could place the tu on a USB drive, and boot it that way?? I don't have a 360 controller anymore, otherwise I'd be more help here.. iirc, the tu should show up in tu section of game options mate.. like any other game..

Share this post


Link to post
Share on other sites
48 minutes ago, that1crzywhtguy said:

How would putting it on a usb drive allow me to boot it? If the game isn't looking for it there...

The kernel will look for it there, aurora won't, as it hadn't been updated to include usb devices, but if the tu is in the correct location on usb, it'll bypass aurora tu management.

 

As of 17349, usb devices has changed, any fat32 device can function as internal hdd (in laymen's terms).. just make a content/(16 0's)/

Like that is found on the internal drive.

Share this post


Link to post
Share on other sites

K, I tried your idea and put it on the USB as instructed, but no change to issue. Indie titles still work just fine from stock dash or dashlaunch, but no go in aurora. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...