Highter

FSD not downloading marketplace covers and banners

42 posts in this topic

Hello everyone, I've got a problem on my FSD recently: It won't download any covers and banners, but still download custom covers from covers.jqe360 and get the gameinfo from marketplace. There's a way to me fix this? Thanks for the attention.

Share this post


Link to post
Share on other sites

im having the same problem. liveblock and livestrong is disabled. it scans the game folder starts to download then goes to 0.00kbps. stays at 0 kbps while the number of items rapidly decline. then when you go to games theres no covers

Share this post


Link to post
Share on other sites

I have a same problem with henryh30 , I think there is something wrong with JQE360's server .

update : I still can get cover but i have to refresh artwork one by one . Then only cover was downloaded , no screenshot no info and banner :(

Share this post


Link to post
Share on other sites

The covers download from XB Live. Custom covers are from JQE

Try again, refresh, make sure live isnt blocked. All fails, reinstall FSD.

I had the problem yesteday, I just deleted FSD and installed it again, and let the covers download, was over 2000 images but I left it be all night long.

Share this post


Link to post
Share on other sites

Unistalled Dashlaunch, Reinstalled FSD, changed a lot of stuff in my router settings, but still wont download :( I wonder if it's a internal problem in my internet, or it has something to do with the server...

Share this post


Link to post
Share on other sites

Unistalled Dashlaunch, Reinstalled FSD, changed a lot of stuff in my router settings, but still wont download :( I wonder if it's a internal problem in my internet, or it has something to do with the server...

Dashlaunch wouldn't cause the problem.

If you don't have livestrong set to true then it should be able to get covers ok, it appears everything on the xbox is fine, the problem is the connection from your xbox to the xbl covers (ie. router, settings)

Can you see this image on your PC

[ I removed link ]

Share this post


Link to post
Share on other sites

have a same problem

You don't need to say, if your having the same issue, stand by and see how and if its resolved :)

Now that you registered, by chance did you click on the link on my last post???

Did it load ok?

Share this post


Link to post
Share on other sites

Dashlaunch wouldn't cause the problem.

If you don't have livestrong set to true then it should be able to get covers ok, it appears everything on the xbox is fine, the problem is the connection from your xbox to the xbl covers (ie. router, settings)

Can you see this image on your PC

http://avatar.xboxli...4D558580817/128

Yes, I can see it :s I really dont know what to change in my router settings anymore :\

Share this post


Link to post
Share on other sites

Done, still not downloading :

Settings > Marketplace Option > Set marketplace locale and see if you can download a cover for 1 game, select it, press y, refresh artwork

Have you this enabled too?

Settings > Cover Downloading > Enable Custom Cover Downloading

Share this post


Link to post
Share on other sites

Settings > Marketplace Option > Set marketplace locale and see if you can download a cover for 1 game, select it, press y, refresh artwork

Have you this enabled too?

Settings > Cover Downloading > Enable Custom Cover Downloading

Already tried it, didn't work too

Yes, it's enabled, custom covers are downloading ok

Share this post


Link to post
Share on other sites

Good news, everything went back to normal :) Guess was something wrong in the server. By the way, thanks for the help irishdave!

LOL, thats good, tho odd that the link above worked. Oh well, at least it works.

work, but army of two 40 days and and madden 13 missing cover

sorry for my english

You're going to get that, I'm missing one. It cant be 100% :)

Try custom download from jqe

Share this post


Link to post
Share on other sites

I guess it's no coincidence that so many people are having the same issue just recently... Mine used to download everything fine, covers from jqe360, and screenshots from xbox.com. Now it doesn't download anything, no cover, no background, no banner and no screenshots... can anybody help?

Share this post


Link to post
Share on other sites

I didn't have any issues getting covers today.

Check your router settings, any firewalls you may have running, set your xbox to be on DMZ. Open ports.

check FSD settings as I previously said to someone else ^_^

Make sure livestrong is false

Share this post


Link to post
Share on other sites

I didn't have any issues getting covers today.

Check your router settings, any firewalls you may have running, set your xbox to be on DMZ. Open ports.

Thanks for the quick replay mate! Have no idea how to do that :\ Can you be more specific?

check FSD settings as I previously said to someone else ^_^

Make sure livestrong is false

I'll check back on the topic to see if there's anything I missed... livestrong is already set to false.

Share this post


Link to post
Share on other sites

Thanks for the quick replay mate! Have no idea how to do that : Can you be more specific?

I'll check back on the topic to see if there's anything I missed... livestrong is already set to false.

As for your router, you need to look at the routers manual.

As for your covers downloading, you should just try again later, or tomorrow.

Some had the problem and it eventually worked.

Share this post


Link to post
Share on other sites

Like, I don't think it has anything to do with router or firewall, since I'm able to do it all manually using fsdhttp and chrome. But I don't wanna do it to every new game I install... it's weird, 'cause it's not even downloading the game description, and neither the developer, genre, and all that text stuff... bummer

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Loading...