jimml

Double Game Path Entries Entries

24 posts in this topic

My setup

Xbox Slim Trinity RGH

Kernal 14719

Dash Launch 3.04

Freestyle 3.0.402

2T External HDD

When I turn on the system I get double game path entries (Setup/Content Settings/Manage Game Paths)

This causes all games to appear twice in the game library.

If I shutdown the system and turn it back on, Everything is normal. No double entries.

Has anyone else had this problem.

Thanks

Share this post


Link to post
Share on other sites

i had same problem, only way to fix it restart fsd/xbox. but still any major changes in hdd duplicates em again. iv reinstalled like 10 times but matter not that.

my db files on my box ROOT folder (game) has same files as in fsd 3 installed folder. i mean all covers and stuff.

deleting root. will kill all game list. deleting fsd3 db will kill all covers.,.. why root has same files ? as installion folder O_O ?

i think this thing is duplicating and making most of bugs iam having....

PS. and iam having aswell ****2T External HDD*****. iv just noticed this.

Share this post


Link to post
Share on other sites

I have been having the same problem ever since I updated to rev483. At some point I notice muliple copies of all my games. I then check the paths and notice they are all duplicated too. If I try to delete the duplicate path, it deletes both copies that appeared under the manage paths section. It also deletes all of the games info for the games in that folder.

The only temporary fix I have found is to do a clean reinstall of F3. unfortunately by the time I setup all of my paths, scan them, rename games and download the artwork and move the multi-disk games it usually broken again. :-(

Here are a few details about my setup. maybe we will find something in common with others experiencing this bug.

I have a jasper with 256mb internal memory unit.

I have a 500gb internal hard drive and a 2tb USB hard drive.

I have 6 paths setup in my manage paths section. 2 on the internal drive and 4 on the usb drive.

connectx is disabled.

Share this post


Link to post
Share on other sites

I've had issues when I add a game path with many titles (such as content00000000 if you have lots of GODs), I cannot remove this game path. (it tells me it's deleting content but it never completes, if I back out and return I find the game path is still there)

The only way to remove the game path was to delete my FSD folder and reinstall from scratch.

Share this post


Link to post
Share on other sites

Last night I did a fresh install last night and setup everything again....

tonight I left the xbox turned on (booted to FS3) and then started to ftp some games over. I then was going to rescan to add the new games and noticed that the duplicates problem has reoccured.

I will cut and paste some info from the DB that may help figure this out.

first my scan paths (notice there are only 6)

ScanPathId   ScanPathDeviceId						   ScanPathPath	  ScanPathRetailTabId   ScanPathDevkitTabId   ScanPathDepth
1		    2020202020202020202020205636334533534A4E   \Content\		 0						    0			  3
2		    2020202020202020202020205636334533534A4E   \Games\		   2						    2			  2
3		    5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4   \Homebrew\	    4						    4			  2
4		    5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4   \Kinect Games\    5						    5			  2
5		    5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4   \Xbox Originals\  3						    3			  2
6		    5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4   \Games\		   2						    2			  2
 

now mounted devices (hmmn... duplicates = bad!!!)

[b]MountedDeviceDeviceId [/b]							[b]MountedDeviceMountPoint [/b]
[size=2][font=courier new,courier,monospace]FFFFFFFFFFFF0B360DE519000000000000000000		OnBoardMU:
F6DBFAD32EB4C26605A9CFE8243553EFF52EB61A[/font][/size][size=2][font=courier new,courier,monospace]		Flash:	
2020202020202020202020205636334533534A4E		Hdd1:
FFFFFFFFFFFF0B360DE519000000000000000000		OnBoardMU:
C1DF6D964233D9D9C687521C78B4BC4D2F069018		HddX:	
B7AA93B6B9B14ECD8471D1ACAD959A8B33534A4E		SysExt:
5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4		Usb0:	
2020202020202020202020205636334533534A4E		Hdd1:
C1DF6D964233D9D9C687521C78B4BC4D2F069018		HddX:	
B7AA93B6B9B14ECD8471D1ACAD959A8B33534A4E		SysExt:
5BD031C2D7F863FDAA321EA49F5DA50C39E19EA4		Usb0:	 [/font][/size]

now the view scan paths info (duplicates again)....

View Scan Paths

[b]	Current Paths[/b]
[b]DevKit Xex Type[/b]			 [b]Retail Xex Type[/b]		 [b]Scan Depth[/b]				[b]Path[/b]
[size=2][font=courier new,courier,monospace]Automatic						 Automatic		3							Hdd1:\Content\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox 360							Xbox 360		 2							Hdd1:\Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox 360							Xbox 360		 2							Usb0:\Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Homebrew						 Homebrew		 2							Usb0:\Homebrew\[/font][/size]
[size=2][font=courier new,courier,monospace]Emulator							Emulator		 2							Usb0:\Kinect Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox Classic					 Xbox Classic	 2							Usb0:\Xbox Originals\[/font][/size]
[size=2][font=courier new,courier,monospace]Automatic						 Automatic		3							Hdd1:\Content\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox 360							Xbox 360		 2							Hdd1:\Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox 360							Xbox 360		 2							Usb0:\Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Homebrew						 Homebrew		 2							Usb0:\Homebrew\[/font][/size]
[size=2][font=courier new,courier,monospace]Emulator							Emulator		 2							Usb0:\Kinect Games\[/font][/size]
[size=2][font=courier new,courier,monospace]Xbox Classic					 Xbox Classic	 2							Usb0:\Xbox Originals\[/font][/size]

There are 431 rows in the contentitems table (this is the correct number!) they each show twice in the UI.

There is only 1 row in the recentlyplayedtitles table and it shows twice in the UI.

I suspect the issue is the duplicates in the mounted devices table and the join logic for the datasets is creating the duplicated data in the UI.

I looked at the debuglog and found that it mounted the devices twice. once with what appears to be a valid device Id and once with a deviceid = ffffffff.

Is there any other information that I can provide to help troubleshoot this issue?

thanks,

broettge

Edited by broettge
idog likes this

Share this post


Link to post
Share on other sites

i also have the same problem as all of the above, tried fresh installs reboots deleting you name it ive tried it, sometimes sorts the problem for a short period sometimes dosent, i have seem to notice though if i disconnect an externall HDD then add a game rescan it happends more frequent, an before u say im pluggin the hdd bk into the usb it came out of, i also disconect it an reconect while xbox is powered down

Share this post


Link to post
Share on other sites

are you all using an ext HDD to store your games?

i thought this, i have games stored on my internal an external, so i disconnected the externall, did fresh install then few hrs later happened again just on internal

Share this post


Link to post
Share on other sites

OK so someone who has this issue needs to boot the console, send me a log file, and send me a copy of your databases. This way i can troubleshoot this. i can't reproduce it so i am going to have to get some data.

Share this post


Link to post
Share on other sites

i had the same problem and best i could figure was it happened after i had moved the ext HDD to the rear USB port after originally being setup on a front one.

solution for me was to plug drives into all the ports then boot into FSD and deleted all paths. powered off, disconnected all but the rear ext HDD with my games, booted back up and set up the single path and its been fine ever since.

Share this post


Link to post
Share on other sites

right i seem to have solved my problem, if i disconect power then unplug usb hdd  and add games plug hdd bk in then power cable works fine no double games, also if im putting a game on the internal hdd, i disconect power unplug externall hdd plug power back in the ftp to internal works fine, for me the double game post seems to be if i plug in or remove a hdd while power is still going to console, also as the guy above said i fine using bk usb ports seem to reduce the problem

Share this post


Link to post
Share on other sites

When i add USB gamepath, FSD adds SySEXT and OnBoardMU with same folder name

USB:games

SYSEXT:games

OnBoardMU:games

 

When i try to play some game i get the error "THE GAME CULDN T START TRY DOWNLOADING THE GAME AGAIN"

Share this post


Link to post
Share on other sites

Same problem, duplicate content paths on boot (from a powered off state), after restarting F3 it's fixed but happens every time. One external HDD. And i've reinstalled from scratch but must have eventually done whatever leads to this because it came back after some time...

If someone can point me to the logs location and I can provide them, I'm relatively new to Dash and F3.

Thanks for the support.

Share this post


Link to post
Share on other sites

When i add USB gamepath, FSD adds SySEXT and OnBoardMU with same folder nameUSB:gamesSYSEXT:gamesOnBoardMU:games When i try to play some game i get the error "THE GAME CULDN T START TRY DOWNLOADING THE GAME AGAIN"

I had that problem with a particular hard drive (a iomega with USB 3.0) and after a lot of reading I found many people had the same problem with those Iomega with USB 3.0 and no solution was ever posted, none that I could find at least. I swapped to another disk and that was the solution...sorry.

Share this post


Link to post
Share on other sites

Did anyone find a fix for this? Not sure if it has anytthing to do with it, but I was reading about people hooking up a USB drive on the back port causing the problem. I just have an internal, but recently plugged in a thumbdrive in the back to update my dashboard. I also re setup my paths. Now I notice every time I create a path, I get two ( SySEXT and OnBoardMU). If I delete one, the other goes. I'm pretty much a newbie and had help setting it up. Any suggestions? I've tried clearing the data and paths. Would deleting anything out of the data folder help? I wasn't sure what's safe to delete out of there and what isn't. Thanks for any advice.

Share this post


Link to post
Share on other sites

Use The Same Usb Port You Used The First Time. When you plug your HDD in another usb port you will have all the games doubled . 

ALWAYS PLUG YOUR HDD IN THE SAME USB PORT ON YOUR XBOX.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Loading...